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Introduction

About this manual

This manual describes the PLUS+1® Service Tool.

Some functions require an add-on license. The functions are described in respective section.

To buy an add-on license, see PLUS+1® Software License Manager Help, AQ152886482086.

For short information about the add-on functions, see Data Sheet PLUS+1® Service Tool Add-on licenses,
AI00000254.

Intended use

In PLUS+1® GUIDE you build your application with drag-and-drop logical components or software blocks
in the graphical interface. It is engineered to accelerate your development process and bring higher
quality machines to market faster.

Use the PLUS+1® Service Tool to download the built application to a controller. You can download
parameters to a controller, then you can log and tune the controller performance.

Safety definitions and reading information

Safety definitions

Warning information

Warning information points out potential dangers which can, if the warnings are not followed, result in
personal injury or product damage.

W Warning

Situation that may result in death or serious personal injury if the instruction is not followed.

Do not to proceed until all stated conditions are met and clearly understood.

C Caution

Situation that may result in damage to the product if the instruction is not followed.

Do not to proceed until all stated conditions are met and clearly understood.

Important information

Important information that is marked as below shall facilitate the work process, operation/handling or
increases understanding of the information.

Information that is important without being safety related.

Reading information

Software items are identified by bold text: Manager panel.

To separate menu levels an arrow is used: File > Open refers to the File menu and the Open command.

Code and file paths are identified by this font: \Danfoss\PLUS1\.

Command name are identified by this font: Ctrl+D.
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IEC 61508:2010 support tool certification references

Contact and reference material are available regarding which versions of PLUS+1® Service Tool carry the
IEC 61508:2010 support tool certification.

Please contact the PLUS+1® Helpdesk.

https://www.danfoss.com/en/products/software/dps/plus1-software-services-support-and-training/plus1-

support-and-services

For complete details regarding PLUS+1® GUIDE and PLUS+1® Service Tool IEC 61508:2010 support tool
certificates, see:

PLUS+1® GUIDE Safety management overview, BC415552583577

https://www.danfoss.com/en/search/?filter=type%3Adocumentation%2Csegment%3Adps

Important information to reduce risk

Your responsibility when designing a PLUS+1® Service Tool application is to include the checking and the
error handling needed to reduce risks in normal and abnormal operating conditions.

The applications that you create with the PLUS+1® Service Tool typically control heavy, powerful, and
mobile off-road equipment such as tractors, cranes, and harvesters.

The PLUS+1® Service Tool has no automatic protections against the risks, such as from bugs in the PLUS
+1® Service Tool software, errors in the PLUS+1® Service Tool user guides, or incompatibilities between
software versions of the PLUS+1® Service Tool.

You must design and test your application to reduce these risks.
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Fault checking and error handling

The following are some items to consider when developing fault checking and error handling for your
application.

Consider:

• How the machine is normally used.

• Possible operator errors and their consequences.

• Industry safety standards and legal requirements.

• Input and output failures and their consequences including:

‒ Joystick, sensor, and other inputs suddenly going to 100 % or to 0 %.

‒ Outputs that control machinery direction, speed, and force suddenly changing direction or going
to 100 % or to 0 %.

• Decide how likely each failure is:

‒ The more likely a failure, the more you need protect against the consequences of the failure.

• The sequence of events and consequences of a fault or error.

• The sequence of events and consequences of an emergency stop.

W Warning

Under normal operating conditions, using this type of machinery always involves risk of personal
injury and equipment damage. Abnormal operating conditions increase the risk of personal injury
and equipment damage.

Downloading and testing your applications

Once you have created an application, you have the responsibility to download and test the application.

You should only download your application to hardware or change software parameters while the
vehicle is not in operation. After downloading, test application operation under normal and abnormal
operating conditions.

You should make sure that:

• Individual inputs produce expected outputs.

• Combinations of inputs do not produce unexpected or dangerous outputs.

• Fault handling and error checking work as designed.
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Learning about the PLUS+1® Service Tool

After successfully creating your first controller application using the PLUS+1® GUIDE, you need to put it to
use now.

Use the PLUS+1® Service Tool to:

• Download an application to a controller

• Log and tune controller performance

• Write parameters to a controller

This manual will help you to understand the following concepts and processes:

• The overall concept of the PLUS+1® Service Tool

• How to download an application file to a controller application

• How to run log pages

• How to change controller parameters

Getting ready

Individual requirements to work with the applications in this manual:

• Fully functional versions of the PLUS+1® GUIDE and PLUS+1® Service Tool programs installed on PC

• A completed controller application to use within the PLUS+1® Service Tool

• The following hardware to download these controller applications:

‒ One PLUS+1® CG150-2 or PLUS+1® DP series display (or a similar third party CAN communication
device)

‒ One 12 to 24 VDC 55 mA power supply

• Working knowledge of the PLUS+1® GUIDE environment, including an understanding to use the full
capabilities of the PLUS+1® Service Tool

Proper hardware has be to connected and installed on a computer before you can use the PLUS+1®

Service Tool. Connect the controller to the CAN communication device.

The graphical images in this manual may appear slightly different, depending on which version of the
PLUS+1® Service Tool is in use.
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CAN hardware installation

It is necessary to install CAN driver software before using the PLUS+1® Service Tool.

1. Plug in the PLUS+1® CG150-2 USB cable to the PC USB port. The Hardware Wizard searches for and
installs CAN software. This may take several minutes.

2. Click Close to close the Driver Software Installation dialog.

The following message appears when installation is complete.

USB drivers can be found in the directory: <Program Files>\Danfoss\PLUS1\<Service
Tool Version>\Misc\.

CAN hardware installation troubleshooting

To resolve issues related to the Danfoss PLUS+1®CG150-2 CAN/USB gateway interface communicator,
perform the following procedure:

1. Close the PLUS+1® Service Tool.

2. Enter the Device Manager in Windows® operating system by selecting: Control Panel > System >
Device Manager.

3. Select PLUS+1® CG150-2 or PLUS+1® Display under the Danfoss > Device Manager.

4. Right-click Danfoss CG150-2 or Display and select Uninstall.
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5. Ensure that the Delete the driver software for this device option is unchecked, then click OK.

6. Unplug the PLUS+1® CG150-2 then plug it back into PC USB port.

The Found New Hardware balloon should appear in the Windows® taskbar. Complete the driver
installation wizard and start the PLUS+1® Service Tool to re-establish connection with the PLUS+1®

CG150-2.
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Using the PLUS+1® CG150-2 USB/CAN Gateway Interface Communicator

1. Select Communication > Gateway > Select Gateway... from the PLUS+1® Service Tool window
menu.

2. Select CG150 from list of available gateways.

Using the PLUS+1® DP Series Display USB/CAN gateway

PLUS+1® DP Series Displays with USB connectivity can be used as a CAN gateway.

Make sure that the display is connected using a supported USB cable (see product documentation).
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1. Select Communication > Gateway > Select Gateway... from the PLUS+1® Service Tool window
menu.

2. Select Display from list of available gateways.

Using the PLUS+1® InterLink gateway

PLUS+1® products with PLUS+1® InterLink capabilities can be used as a gateway.

1. Make sure that the device is accessible through Wi-Fi/Ethernet/Bluetooth/USB (see product
documentation).

2. Select Communication > Gateway > Select Gateway... from the PLUS+1® Service Tool window
menu.

3. Select PLUS+1 InterLink from list of available gateways.

The PLUS+1® Service Tool will search for available PLUS+1® InterLink devices, and these devices will
be available as channels.
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4. Select gateway settings.

PLUS+1 InterLink settings

CAN Interface Routing Determine which CAN port(s) of the PLUS+1 InterLink gateway should
participate in routing of CAN messages.

Enable CAN tunneling Select to enabled reception of CAN messages from the PLUS+1 InterLink
gateway. CAN tunneling needs to be enabled for CAN messages to be
displayed in CAN Monitor and to use CAN Xplorer protocol.

5. After selecting the desired channel, a Gateway Password dialog will show up if the gateway is
password protected. Enter the correct password and press the Connect button to connect.

6. Check the Remember password check box to save the password.

Using the PLUS+1® Virtual CAN gateway
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1. Select Communication > Gateway > Select Gateway... from the PLUS+1® Service Tool.

2. Select PLUS+1® Virtual CAN Gateway from list of available gateways.

For further information, see PLUS+1® GUIDE User Manual.

Using the PLUS+1® InterLink Remote gateway

PLUS+1® products with PLUS+1® InterLink Remote capabilities can be used as a gateway.

1. Select Communication > Gateway > Select Gateway... from the PLUS+1® Service Tool window
menu.

2. Select PLUS+1 InterLink Remote from list of available gateways.

3. Click Log in to log in or sign up for a Danfoss Profile. Once authenticated the device list will display
the list of your PLUS+1® InterLink Remote devices and the state of each device. Click Refresh to the
update the state of the available devices.
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4. Click OK to connect to the selected device.

By default, routing to all CAN interfaces is enabled. This means that any PLUS+1® device connected to the

CAN interfaces of the remote gateway will be accessible in PLUS+1® Service Tool. This functionality can be

configured in the CAN Interface Routing list before connecting to the device.

Using the third party Gateway devices via the RP1210 standard

The PLUS+1® Service Tool supports the generic communication standards RP1210B & RP1210A for any
compliant third party gateway. These recommended practice standards were written by the Technology
and Maintenance Council (TMC).

• RP1210B gateways may not support all baudrates that the built-in gateways support.

‒ RP1210B gateways can be used if they support the generic CAN protocol.

• RP1210A gateways only supports baudrates equal to 250k.

RP1210A gateways can be used if they:

‒ Support the generic CAN protocol

‒ Support blocking calls

‒ Use the same endianness (byte order) for CAN messages as RP1210B

• Activate RP1210 gateways by selecting the appropriate DeviceID in the submenu under the gateway
submenu. All possible device IDs will be listed for selection. Devices do not need to be connected to
the computer to be listed.

Connection

When an RP1210B or RP1210A gateway has been properly installed, it will be automatically added to the
list of installed gateways under Communication > Gateway after the PLUS+1® Service Tool is restarted.

The name of the new gateway consists of the name of the standard implemented (RP1210B or RP1210A)
plus the name of the gateway vendor as written in the vendor supplied .ini file. The order of gateways

in the list is determined by the global RP121032.ini file.

Diagnosing gateway warnings and errors using the RP1210 standard

Configure an RP1210 gateway using its .ini file. It is important that the .ini file follows the standard.

If the PLUS+1® Service Tool has problems reading the .ini file, an error or a warning message will occur. If
an error is found, it will not be possible to use the gateway from the PLUS+1® Service Tool. If warnings are
found it will still be possible to use the gateway, but a communication slowdown will occur. This
slowdown can be overridden by the user. See Using Reset Gateway in advanced settings on page 16 to fix
a gateway error manually.

Diagnose will be a choice under Gateway to select to examine any detected errors and warnings.
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Advanced users may wish to use the View RP1210 parse log to troubleshoot RP1210 gateways that may
not be working well with the PLUS+1® Service Tool.

Select Communication > Gateway > Advanced > RP1210 Log from the PLUS+1® Service Tool window
menu.

The contents shown in the RP1210 Parse Results window is generated from the code and never stored
in a specific file.

A gateway that does not implement RP1210B, but only RP1210A will generate a warning message.

Using Reset Gateway in advanced settings

Reset Gateway can be used to:

• Search for gateway changes

• Manually fix a gateway error that is not automatically detected

Virtual Mode

The Virtual button in Communication > Gateway > Select Gateway... changes to Virtual mode directly.
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For further information about Virtual Mode, see PLUS+1® Service Tool Service Tool Design Manual.
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Managing Protocols values

Protocols must be installed and selected before they can be used. This can be done in the Manage

Protocols window. More than one protocol can be used at a time.

The PLUS+1® Service Tool also supports the use of communication protocols other than the standard
PLUS+1® protocol, but not all PLUS+1® features may be functional if a different protocol is used.

To manage communication protocols, select: Communication > Protocols....

This opens the Manage Protocols window, see below:
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Selecting Add Protocol opens the window, where all installed protocols can be seen and managed. The
Manage Protocols window displays the following values:

Manage Protocols Values

ID All protocols have an assigned ID number from 0 to 255. PLUS+1® protocol is always 0
and Virtual is always 255.

Name Protocol name.

DLL Path Location folder of actual DLL file.

Data Path Location of a created folder where protocol-related information can be stored. This
location can be changed by the user.

Active Selection Box Check box checked: protocol is active.

Remove Link to remove protocol from system.
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Add new protocols

1. Add new protocols by clicking the Add Protocol button in the lower left corner of the Manage
Protocols window.

2. Select a protocol DLL in the Select Protocol DLL dialog and click Select to confirm the choice.

The added protocol will now appear in the protocols list of the Manage Protocols window with an
assigned ID number.

3. Use the Manage Protocols window to check data path, activate, remove or modify options for the
protocol. When finished, click OK.

The protocol is added and ready for use.

When using multiple protocols in a system, make sure that the protocols will not interfere with each
other. High bus load may occur when using many protocols at the same time.
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Protocol options

Protocol option values can be changed.

1. In the Manage Protocols window, select a protocol in the list to view the protocol options displayed
in the bottom part of the dialog.

The options and information for each protocol will vary.

2. Click the value in the Edit field to edit the option value.

3. Click OK to save and use the updated option values.

Options for protocol window

Name The name of the option.

Type Setting type.

Description A short description of the setting.

Value The current value of the setting.

Edit The editable properties of the setting. If field is empty, the setting is not editable (see editing
properties for more information).
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PLUS+1® Service Tool Window Description

Item Name Description

1 Menu bar Use to access PLUS+1® Service Tool commands and information.

2 Toolbar Use to access common PLUS+1® Service Tool commands and information.

3 System Navigator Use to show a tree view of all hardware and software applications within the PLUS+1® Service Tool.

4 Work area The area where all PLUS+1® Service Tool functions are performed.

5 Service function status Displays information of current PLUS+1® Service Tool function.

6 Controller connection
status

• Green — Controller connected

• Blue — Logging or Downloading

• Yellow — Searching for connection

• Red — Controller disconnected or gateway error

7 Log period status Displays the requested and actual log period settings in the application.

8 CAN device information Displays connected CAN/USB gateway interface communicator information.

9 CAN baudrate Displays the baudrate setting for the CAN/USB gateway interface communicator.
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Start page

The start page is available by default when no Service Application is open in PLUS+1® Service Tool. It can
be disabled in Options under General (or new page number if changed).

PLUS+1 Service Tool start page

Item Description

File Download… Displays the Open Download File dialog. Once a file is
selected, the Download File dialog is displayed.

New Service Application Creates a new empty Service Application.

Open Service Application... Displays the Open Service Application dialog. Use this
dialog to locate and open Service Application files.

Recent Service Applications A list of recently opened Service Applications. Select a
Service Application to open from this list.

Bookmarked Service Applications A list of bookmarked Service Applications. Select a
Service Application to open from this list.

Tutorials A list of tutorial links into the HTML version of the user
and design manuals.

Update Center Shortcut to start the PLUS+1® Update Center.

PLUS+1® Forum Shortcut to the PLUS+1® Forum online.

PLUS+1® Channel Shortcut to the PLUS+1R YouTube channel.

Helpdesk Support Contact information to PLUS+1® Helpdesk.
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System Navigator features

The System Navigator section of the PLUS+1® Service Tool window contains and displays important
information for the PLUS+1® Service Tool.

It is possible to copy the ECU list information to the clipboard, by right-clicking the ECU List node and
selecting the menu item Copy ECU List to clipboard.

The System Navigator area is the starting point for all PLUS+1® Service Tool functions.

Use the System Navigator to:

• Set and display system information

• Store and access documents (right click on Documents icon to add, remove or hide documents in
Normal view)

• Set and display ECU information

• Display Net, node and hardware information

• Create, open and arrange Log and Parameter pages

• Store and display PLUS+1® Service Tool activity history

Information in the System Navigator is arranged in a hierarchical style. Sections can be expanded or
minimized as needed.

Locking and unlocking Diagnostic Navigator pane

Unlock the Diagnostic Navigator pane:
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1. Drag the pane by the undocking bar to separate it from the main window.

Drag to unlock (docked)

Lock the Diagnostic Navigator pane:

2. Double-click on the title bar at the top of the window.

The Navigator pane snaps to its default position.

Double-click to dock (undocked)

Hide the Diagnostic Navigator pane:

3. Toggle either the Diagnostic Navigator button in the status bar or Diagnostic Navigator in the View
menu.

Display the Diagnostic Navigator pane:

4. Move the mouse cursor to the left side of the PLUS+1® Service Tool window or click the System
Navigator button on the toolbar again.

Restoring default layouts

Select View > Default Layout to restore the PLUS+1® Service Tool window settings to the default
layout.
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Installing tool languages during setup

When setting up the PLUS+1® Service Tool, install additional languages in the Select Languages

page.

Selecting the PLUS+1® Service Tool language

To select the preferred PLUS+1® Service Tool language, select Tool language in the General Settings.
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To select the default language (English), select Options > Language > Default Tool Language.

This can also be done by selecting Ctrl+Alt+F.

Selecting the Service Application language

When a multilingual Service Application is active and the tool is in Normal View, select Options >
Language > Select Service Application Language.

Alternatively, you can select the preferred language in the drop-down list of the toolbar.
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Preparing to Download the Application File to the Controller

1. Click the File Download button in the PLUS+1® Service Tool window toolbar.

This can also be done by selecting System > File Download or Ctrl+D command.

2. Browse in the Open dialog box and click the file name of your application, then click Open.

It is possible to select multiple download files.

3. Select the target ECU in the ECU drop-down list and click Next.

The download file is now ready for downloading.
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4. Check the Show report after download checkbox to get a report of the download.

It is possible to configure the PLUS+1® Service Tool to automatically save download reports to a
specific folder. If this functionality is enabled, the Show report after download checkbox will not be
available.

5. Click Start Download to download the application.
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A progress bar is shown while downloading

It is recommended that there are no other applications running on your PC while downloading the
application file. This will speed the file transfer process up and help to avoid possible system and
application conflicts.

C Caution

To avoid possible system and application conflicts, do not disconnect or power off the system during
the download process. The PLUS+1® Service Tool will automatically rescan the controller when the
download is completed.

• If the target OS version does not match the file OS version when attempting to download, a
warning message will be shown in the Application File Information in the Download File to ECU
window:

• If the target application file type does not match the file application type for the file that is to be
downloaded, a warning message dialog box will appear:
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When the download is completed, the application is ready for testing.

6. Click the Save Report button when the download is finished to create a report file.

Downloading system download packages

When using system download packages, there will be a list of individual downloads (1-∞) in the list. It is
possible to check/uncheck individual downloads, depending if they are mandatory or not.

1. Click Next to see eventual parameter settings.

2. Click Start Download to start all downloads.

Mandatory applications/missing ECUs

Applications might be mandatory in a package. It is not possible to deselect these applications during the
download sequence.
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If no valid ECU is found for the mandatory application, it will not be possible to continue the system
download.

Retry downloads

It is possible to retry a failed download. The successful downloads will be unchecked by default, and the
failed download will remain checked.
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Press the Retry Download button to retry the failed downloads.

Parameter settings during the application download

Parameter Settings - Values dialog window will appear when downloading applications with common
parameters.

• The upper field shows information about the current application and the application to be
downloaded.

• The lower field shows changes in the parameter structure.

The Status icons display more detailed information about the parameter. Only parameter values that are
checked in the Parameter Values dialog box will be downloaded during file download.
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If restricted parameters exist, a warning message will be displayed.

• Restricted parameters will be transferred automatically.

• New restricted parameters will be set to zero.

• Restricted parameters with changed parameter type will be transferred if the value is valid within the
new parameter type; otherwise the parameter value will be set to zero.

Use the Parameter Setting pull-down selection to define parameter setting behavior:

• Automatic selection will transfer values where the memory locations have been changed.

• Set to Zero will set all parameter values to zero (parameter values with restricted access will be
transferred to the new application).

• User Defined is automatically selected when custom changes are made. All fields that are white (not
grey) are possible to change manually.

An option is available whether to always display the parameter settings dialog, or only when the
parameter structure is changed.
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The correct Tool Key for the current application must be supplied before the download to be able to
transfer the parameter values automatically. If not, a warning dialog will be displayed. If you continue the
download, parameter values will not be transferred to the new application.

A warning message will be displayed if the target ECU contain parameters with invalid parameter values.
Valid values need to be supplied in the Parameter Setting dialog for the parameters to be written during
the file download.

Recover ECU functions

The Recover ECU is available for all protocols (where supported), and not only the PLUS+1® protocol. A
protocol field is available in the Recover ECU dialog.

It is also possible to install diagnostic data files for all protocols (where supported).
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To use the Recover ECU functionality with a display or RP1210 gateway it is required to have at least 3
units attached to the CAN Bus: The diagnostic interface, the ECU to recover, and at least one hardware
that can do acknowledge on the CAN messages sent by the PLUS+1® Service Tool.
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Introduction to service application files

In order to interface with an ECU application, a service application file is needed. Service application files
can contain both Log and Parameter pages.

There are two ways to open service application files in the PLUS+1® Service Tool application.

• Manual load service application files

• Scan for service application files

Log page

Use the Log page to:

• Monitor application activity

• Enable data logging to file

• Export log data to Microsoft Excel®

Parameter page

Use the Parameter page to:

• Read and write PLUS+1® GUIDE profiles and parameters

• Import and export created parameter files

• Generate database reports of parameter values

Manual Load of Service Application Files

1. Select File > Open
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2. Select System Application files to load to the System Navigator.

Scanning for service application files

Use Scan for Service Application File... to load service application files:

1. Select File > Scan for Service Application File...

If the connected system contains a System ID, that System ID will be used to find matching service
application files. All service application files that contain an exact matching System ID will be
displayed in the results dialog.

If only one matching file is found, this file will be opened automatically.

Matching files are added to the list while searching.

2. To open a matching file and close the search dialog, select the desired file in the list and select Open.

Refer to the PLUS+1® GUIDE User Manual, AQ152886483724 for instructions how to enter System IDs
into PLUS+1® GUIDE.

The PLUS+1® Service Tool will search for service application files in the following locations:
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• Any service application file that has been previously opened

• Files in the My Documents Danfoss\PLUS1\GUIDE Service Tool\Service
Application Files Folder

If no System ID is available in the connected system, files will be matched using the Net/Node
Number, Application ID, and Application Type of the file and connected system. An exact match of all
ECUs in the file and system is required.

Boot loader mode

After downloading an application, the system is scanned for new diagnostic data to load.

If the connection is broken during the application download, the ECU will go into boot loader mode.

When the ECU is in boot loader mode the ECU will be displayed red in the System Navigator.

Downloading a valid application will take the ECU out of boot loader mode.
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Automatic scan for service application files

The PLUS+1® Service Tool can be set to automatically open the correct P1D after scanning the system in
normal view.

The option Automatically scan for Service Application File must be enabled in the PLUS+1® Service
Tool settings for this feature to be active.

When enabled, the Scan for Service Application File function on the File Menu will be activated after
each system scan.

1. Enable the feature by selecting Automatically scan for Service Application File in the General
section of the Options dialog box.
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2. Click OK to save your selection and close the Options dialog box.

The Automatically Scan for Service Application File will only be activated if the connected system
contains a System ID.

Opening hardware service files

There are two ways to open hardware service files in the PLUS+1® Service Tool application:

• The PLUS+1® Service Tool can scan for hardware service files

• Files can be manually loaded

1. Open the PLUS+1® Service Tool.

2. In the System Navigator, right-click on the ECU and select option.

• Scan for Hardware Service File...

• Load Hardware Service File...

Manual installation of diagnostic data files

In the PLUS+1® Service Tool, diagnostic data files are automatically installed when a P1H/P1D or LHX file is
opened.
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Diagnostic data files can also be installed manually by selecting Options > Install Diagnostic Data.

1. Click Install Diagnostic Data...

Active communication protocols that support Install Diagnostic Data files are listed.

2. Select from the list of active protocols to display the installed diagnostic data files.

3. Select a data file to install or uninstall.

A new file can be added by leaving all selections unchecked and clicking Install.
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4. After clicking install, select a file to install from the Open window. Click Open to install.

An installation dialog window will confirm the status of the file installation. Unsuccessful installations
will be shown in red with the reason for the failed installation.
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Logging controls

1. In the menu bar of the main PLUS+1® Service Tool window, select Communication > Start

Communication to begin log activity.

2. To stop logging, select Communication > Stop Communication.

3. Logging can be monitored in any or all of the four log file views chosen in the Design Diagnostic
Page. Click through the tabs to change log views.

4. Logging controls can also be accessed through the button controls above the Log view work area.

Button controls above the Log view area

Button Description

 /

Start logging / Stop logging toggle button

Record to file

Recording log files

1. Record log files by using the record to file function. Select Communication > Record to File from the
PLUS+1® Service Tool window menu. When the recording has been started, log data recording will be
automatically saved.
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2. When recording is stopped, select or create a log file to save in the Select logfile window.

Any logging activity will be recorded in a log file. Logfiles (*.LDF) for basic pages will be stored as
LDF/LHF files.

Log files for advanced pages will be stored as LDF/GEN files in the selected log folder.

Monitor log files

1. Verify Log to File activity by monitoring Log status box in lower left hand of PLUS+1® Service Tool
window.
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2. To play saved log files select Communication > Open Log File... from the PLUS+1® Service Tool
window menu bar or click the Open Log File icon from the PLUS+1® Service Tool window toolbar.

3. Select the file from the Open dialog window and click Open.

Log file playback

Click the Play icon in the PLUS+1® Log File Viewer window toolbar.

Only data is displayed during playback of basic log pages. Images, if added, are not displayed.

Log file playback information (activity status, file name, date and time stamp) is displayed in the
bottom left-hand corner of the PLUS+1® Log File Viewer window.

Log file playback can be controlled by using the Position Slider, Play, Stop, Pause and Step Forward in
Log File controls.

Log file process

There are two ways to open logged file:
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1. Select from the PLUS+1® Service Tool window menu Communication > Open Log File...

2. Click from the Communication toolbar Open > Log File

3. Select Log File in the Open dialog box, and click Open.

The Log File is now open in the PLUS+1® Log File Viewer window. Multiple log files may be opened at the

same time.

Exporting log files to spreadsheet

Log files can be exported to any CSV format spreadsheet program (such as, Microsoft Excel® and Google
Docs™). The PLUS+1® Service Tool defaults to Microsoft Excel® csv delimiters for exporting database files.

Default delimiter:

1. In the PLUS+1® Service Tool, select Communication > Open Log file...
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2.
In the Log File Viewer, select Export 

3. Save As dialog box , click Select the file for export in the Save.

The file will be exported and saved as a .csv file to the Log folder of the application.

4. Click OK.

The file is now ready to be opened with Microsoft Excel®.

Selecting a different delimiter:

In the PLUS+1® Service Tool, select Options > Settings.
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Manual parameter upload and download

1. Use the Parameter Read and Parameter Write functions to enter and verify operating values to the
controller.

2. Read parameter values to the PLUS+1® Service Tool from the controller by selecting Parameter >
Read from the PLUS+1® Service Tool window menu.

Parameters can also be read using the Read button from the toolbar.

3. Write parameter values from the PLUS+1® Service Tool to the controller by selecting Parameter >
Write in the PLUS+1® Service Tool window menu.

Parameters can also be written using the Write button from the toolbar.

In a basic parameter, controller values are updated in the ECU values fields of the Design Screen

(Basic) pane of the PLUS+1® Service Tool window.

Upload or Download parameters from or to ECU

Only Parameters selected for writing will be written.

Selecting parameter for writing

1. Download parameter values by checking the Write check box for each parameter to write, and press
the Write parameters button in the toolbar.

Basic Parameter List view

Advanced Parameter Page view

When changing a parameter value, the check box will automatically be checked.
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Unchecked parameter values will not be written.

2. Press the Check All button to check all parameters in the list.

3. Press the Uncheck All button to uncheck all parameters in the list.

4. Press the Set default button to set all parameter values to the default value (specified in design
mode).

Use a period (.), a comma (,) or the decimal symbol from the Windows regional settings when
entering decimal values.

Importing parameter values

When importing parameters, an error dialog will show up if any values (from file) are not within the
parameter range set by the designer.

Parameter Write Summary

If Parameter Write Summary is enabled for the page, a summary dialog will be shown before writing
parameter values to the ECU(s).

The summary contains a list of all parameters on the specific page with write status, current parameter
values and the values that are about to be written. Make sure that the new values are correct before
pressing the Write button.

It is not possible to edit the write status or the values that are about to be written in the summary dialog.
If the values are not correct, press Cancel to return to the page to correct the values.

Automatic parameter read function

ECU parameter values are automatically read when a parameter page is selected.
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If Cancel is selected, parameter values will be set to the default settings. A notification message will be
displayed.

If the ECU is not connected, parameters will not be automatically read.

Parameter read and write error messages

If errors occur during parameter read and/or write, error messages will be displayed.

In basic pages, parameters containing errors will be marked by red exclamation circle.

In advanced pages, parameters components containing errors will be shown in the tool tip.

If the property “Indicate changed value” has been enabled by the designer, the parameter edit field
background will turn yellow when the edit value differs from the current ECU value.
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Parameter file export

1. Created parameter files can be imported or exported from a local PC. To export, select Parameter >
File Export.

These files are called parameter data files and are saved in a xml file format.

Parameter data files contain the ECU, signal name and value together with a version number on the
file format.

2. Save the parameter data file using the Save As dialog box:

Only the currently displayed and available parameter values can be saved.

If the user does not have access to the parameter, the parameter cannot be saved.

Parameter file import

1. Import files by selecting Parameter > File Import.
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2. Select the desired file for value import.

Only values for displayed signal names in the current parameter page will be changed.

The imported file data uses signal names to reference imported value locations.

If no signal name match is found, data will remain unchanged. Parameter values that are locked will
remain unchanged.

Generating parameter reports

Database readable reports of parameter activity can be generated using the Generate Report function.

1. In the PLUS+1® Service Tool window menu, select Parameter > Generate Report or press Ctrl + R.

or

2. Name the file in the Generate Report dialog box.

The file will be saved as a .csv file.
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The file can be opened by many common database applications, such as Microsoft Excel®.

Parameter memory transfer

Parameter memory values can be transferred from one controller to another using the Parameter
memory transfer feature.

All parameters referenced in the diagnostic data (except those that are write-protected) can be read and
written regardless of user access level.

The memory value that is transferred is from the NV (non-volatile) memory value and not the VAL (value)
signal.

For more information on the difference between NV and VAL values, reference the PLUS+1® GUIDE User

Manual, AQ152886483724.

Read parameter values

1. Right-click the current ECU of an open application in the PLUS+1® Service Tool window. Select ECU

Parameter Transfer to open a submenu.
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2. Select Read all parameter values.

3. In the ECU Parameter Transfer - Read dialog window name the file and click Save.
The parameters will be stored as a .P1T file.

Write parameter values

1. Right-click the current ECU and select ECU Parameter Transfer.

2. Select Write all parameter values.
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3. In the ECU Parameter Transfer - Write dialog window select desired .P1T file and click Open. The
parameter values will then be transferred to the current ECU.

This will write all available parameters into the current ECU.

It is only possible to write parameter values to an application which matches the parameter set in

the .P1T file.

If a parameter cannot be read or written, a Parameter Read/Parameter Write Error dialog window will
be displayed. Specific parameter and error information will be listed.

Decrypting P1T files

Only .P1T files created in PLUS+1® Service Tool 10.0 or later can be decrypted.

1. Decrypt a .P1T file to view the ECU and parameter information by selecting the menu item
Parameter > ECU Parameter Transfer > Decrypt ECU Parameter Transfer file...
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2. In the ECU Parameter Transfer - Decrypt dialog window select desired .P1T file and click Open.

3. In the next ECU Parameter Transfer - Decrypt dialog window name the file and click Save. Two
output formats are available, .CSV and .JSON.

If the ECU application, from which the .P1T file was created, required a Tool Key, then the same Tool Key

must be active in the PLUS+1® Service Tool to be able to decrypt the .P1T file.

The content in the decrypted information will depend on the access levels in the active license.
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Decrypted P1T file types

Parameter Transfer files (P1T), can be decrypted into two different formats, JSON and CSV.

Adding matching criteria

When decrypting a P1T file, the decrypted file with contain a placeholder for matching criteria. This can

be used to specify/limit which ECU or application the P1T can be written to. Two types of matching

criteria can be specified, ECU information and parameter values. If a certain or a certain set of ECU
information items are selected as matching criteria, this information must be matched in the ECU/
application to allow the created P1T being written to the ECU. If parameter values are added to the

matching criteria, the parameter values will be read from the ECU, and if the parameters are available in
the ECU and the values are correct according to the file, the file can be written to the ECU. The two types
can be combined.

The following ECU info are valid as ECU info matching criteria:

• Node address

• Application ID

• Application type

• Application version

• Compile time

• OS family

• OS software

• OS info

• Tool version

• Bootloader version

• EAN

• Serial number

• Manufacture date

• Part number 0

• Part number 1

• Part number 2

• Part number rev 0

• Part number rev 1
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JSON format

JSON file example:

{
    "formatVersion": "1.0.0",
    "comment": "",
    "ecuInfo": {
        "nodeAddress": "3",
        "appId": "Example",
        "systemId": "",
        "appType": "",
        "appVersion": "",
        "compileTime": "2023-08-16 11:15:29 51",
        "os": "10101829_10101468v270 _TI2812 6.49",
        "osFamily": "10101829",
        "osSoftware": "10101468v270",
        "osInfo": "TI2812 6.49",
        "ean": "",
        "serialNumber": "000004490484",
        "manufactureDate": "2004-12-03 11:51:56 59",
        "bootloaderVersion": "130",
        "partNo0": "0001020304",
        "partNo1": "0111213141",
        "partNo2": "",
        "partNoRev0": "06",
        "partNoRev1": "71",
        "toolVersion": "2022.3.7",
        "accessRightsControlledByApplication": "0",
        "licenseReadAccess": "0",
        "licenseWriteAccess": "0",
        "toolKey": "",
        "matchingCriteria": [
        ],
        "parameterInfo": [
            {
                "name": "NV1",
                "type": "U8",
                "value": "1",
                "readAccess": "9",
                "writeAccess": "9",
                "flags": "APP",
            },
            {
                "name": "NV2",
                "type": "U16",
                "value": "2",
                "readAccess": "9",
                "writeAccess": "9",
                "flags": "APP",
            },
            {
                "name": "NV3",
                "type": "U32",
                "value": "3",
                "readAccess": "9",
                "writeAccess": "9",
                "flags": "APP",
            }
        ]
    }
}
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Matching criteria example

In this example, a matching criterion has been created which requires the appId and osFamily to match,
and the values of PARAMETER1 and PARAMETER2 must match.

"matchingCriteria": [
          "appId",
          "osFamily",
          {
            "parameters": [
              {
                "name": "PARAMETER1",
                "value": "123"
              },
              {
                "name": "PARAMETER2",
                "value": "456"
              }
            ]
          }
        ]

CSV format

CSV file example:

ECU Information:
NodeNumber;ApplicationID;ApplicationType;ApplicationVersion;SystemID;C
ompileTime;OS;OSFamily;OSSoftware;OSInfo;EAN;SerialNumber;ManufactureD
ate;BootloaderVersion;PartNumber0;PartNumber1;PartNumber2;PartNumberRe
v0;PartNumberRev1;ToolVersion;AccessRightsControlledByApplication;Lice
nseReadAccess;LicenseWriteAccess;ToolKey;DiagnosticSession;Comment
3;Example;;;;2023-08-16 11:15:29 51;10101829_10101468v270 _TI2812 
6.49;10101829;10101468v270;TI2812 6.49;;000004490484;2004-12-03 
11:51:56 59;130;0001020304;0111213141;;06;71;2022.3.7;0;0;0;;;
Matching Criteria:
MatchingCriteria;Name;Value
Parameter Information:
ParameterName;ParameterType;ParameterValue;ParameterReadAccess;Paramet
erWriteAccess;ParameterFlags;ParameterAddress
NV1;U8;1;9;9;APP;
NV2;U16;2;9;9;APP;
NV3;U32;3;9;9;APP;

Matching criteria example

In this example, a matching criterion has been created which requires the appId and osFamily to match,
and the values of PARAMETER1 and PARAMETER2 must match.

matchingCritera;Name;Value
appId;"";""
osFamily;"";""
parameters;"PARAMETER1";"123"
parameters;"PARAMETER2";"456"
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Creating P1T files

P1T files can be created based on a decrypted .CSV or .JSON file.

1. Select the menu item Parameter > ECU Parameter Transfer > Create ECU Parameter Transfer

file…

2. In the ECU Parameter Transfer - Create dialog window select desired .CSV or .JSON file and click
Open.

If the input file does not contain a Tool Key (or if it is invalid) a dialog will show up, where a Tool Key
can be added (recommended).
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3. In the next ECU Parameter Transfer - Create dialog window name the file and click Save.
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Contextual help feature

Service applications may contain contextual help. Contextual help is available when the screen cursor is
placed over an advanced page component subject and a question mark is displayed.

Press F1 to display the help topic relevant to the "context" in which the user pressed the key.

For example, pressing F1 in an editor could display a topic on editing, pressing F1 in a configuration
dialog could display a topic on the features of that dialog.

Tool Key Set Up
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Tool Key function

Use the Tool key function to provide customized application protection. For information on license
embedded Tool Key options, consult your nearest Danfoss technical sales representative.

There are three ways to set up the Tool Key:

• Manually entered

• Included or embedded in the Service Application File (P1D)

(See PLUS+1 Service Tool Design Manual for information about setting up Tool Keys in the P1D)

• License embedded

Set up Tool Key information

When downloading the application with Tool Key for the first time it will be necessary to set up the Tool

Key information in the PLUS+1® Service Tool.

1. When no Tool key information is found when attempting a download, the following warning
messages will appear:

2. Enter Tool Key information by first clicking OK to close the Incorrect Tool Key error message.

3. Next, select Options > Tool Key... from the PLUS+1® Service Tool window menu to open the Tool Key
dialog box.
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Manually entered Tool Key set up

1. In the Tool Key dialog box select Add.

A sub dialog box appears.

2. Enter the Tool Key name (description) and the Tool Key password that was created in the PLUS+1®

GUIDE application. Click OK to close box.

The Tool Key has successfully been entered.

3. Select OK to save and close.
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License embedded Tool Key set up

Tool keys embedded in the active license will appear in the License Tool Keys field of the Tool Key

dialog box.

1. Select Tool Key and click OK to activate the selected Tool Key.

2. Select Add....
The Tool key is now active.
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Application log

Record application activity for supported applications and controllers in the Application log function of
the PLUS+1® Service Tool. The Application Log writes application-specified information to a flash memory
file (PLA file) that can be accessed in the Diagnostic Navigator section of the PLUS+1® Service Tool.

Application data logging writes data to the memory of a Danfoss PLUS+1® controller. The PLUS+1®

Service Tool program accesses this data. The program writes data first to an encrypted .p1a (PLUS+1®

application data log) file and then, with proper access rights, writes to a CSV (comma-separated value)
file.

Access to application log information can be controlled within the PLUS+1® GUIDE software program.
You can use access components to restrict the PLUS+1® Service Tool program's access to the application
data log and its contents.

For more information, see the Application Data Logging chapter of the PLUS+1® GUIDE User Manual,
AQ152886483724.
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Application log file

1. Double-click to open the encrypted log file.

The file will automatically decode to create and save to an ASCII file.

The Application Log file can now be decoded into a csv file that can be accessed by many
spreadsheet applications.

2. Select in the PLUS+1® Service Tool window menu bar: System > Decode Application Log File...
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3. Select the file to be decoded.

An Application Log File that matches the user access level is created.

Signal Logger

Signal Logger is a diagnostic tool used to log signals to a buffer in the PLUS+1® controller RAM. The
logged data is displayed in a graph and can be exported to a CSV (comma-separated value) file. The
buffer can be logged from a connected ECU device or loaded from a CSV file containing pre-logged data.

It is possible to a configurable subset of all signals that are accessible to the PLUS+1 Service Tool e.g
Kernel API signals and Application signals defined by NY, Check Point, Set Value and Set Pulse
components in PLUS+1 Guide. It is possible to configure the sampling rate, given a defined set of
possible fundamental sampling periods. It is also possible to configure a Maximum duration defining for
how long the Signal Logger will continue to capture data frames after the trigger condition occurred.

The Signal Logger has a trigger function and it is possible to configure:
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• A trigger condition that defines when the capturing of data frames starts.

• A buffer which contains data frames captured before the trigger condition occurred.

1. To open the Signal Logger window, go to Tools and select Signal Logger.

From the Signal Logger toolbar you can access the Signal Logger commands.

Signal Logger toolbar

Item Description

Configure ECU Opens the Configure Signal Logger window. Here you can select
ECU, sampling signals, configure sampling and trigger events.

Start Logging Starts logging data to the buffer.

Load from file Loads a previously saved configuration file (.xml).

Save Saves the configuration file (.xml).

Reset Zoom Resets the zooming of the graph.

Options Opens the Options window. Here you can choose the settings for the
graph.

Close Closes the Signal Logger window.

2. To configure a signal, select Configure ECU in the Signal Logger toolbar.
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3. In the Configure Signal Logger entry fields, select the connected ECU and signals to log.

You can also choose settings for Sampling Configuration and Trigger Configuration.

The Sampling Configuration field let you configure the sampling of signals and define parameters
such as Period, Maximum Duration and Period Multiplier of the sampling.

The sampling Period is a list of available periods in the Kernel. When selecting a Period it is then
multiplied by Period Multiplier . The Maximum Duration is defined in milliseconds and when the
logging of signals starts (see Trigger below) it will continue for the defined duration or until the log
buffer is full or the Signal Logger is stopped, whichever comes first.

In the Trigger Configuration field you can define the trigger event for one of the signals. The trigger
type may be configured as Run, Differential or Edge. The slope may be set to Rising, Falling or
Both.
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Trigger Configuration settings

Item Description

Type

Run (manual) The trigger will occur immediately when logging is enabled (manual start).

Edge The trigger will occur when the trigger threshold is crossed (rising edge, falling edge or
both.

Differential The trigger will occur when the difference between two consecutive samples is detected.

Slope

Rising The trigger will occur on positive edge only when the threshold is crossed from below.
For boolean values threshold won't be taken into account.

Falling The trigger will occur on negative edge only when the threshold is crossed from above.
For boolean values threshold won't be taken into account.

Both The trigger will occur on both edges when crossing the threshold.
For boolean values threshold won't be taken into account.

Differential

Positive Difference The trigger will occur when a positive difference between two consecutive samples is
detected.
For boolean values this method is undefined/unsupported.

Negative
Difference

The trigger will occur when a negative difference between two consecutive samples is
detected.
For boolean values this method is undefined/unsupported.

Both The trigger will occur when either a negative or a positive difference between two
consecutive samples is detected.
For boolean values this method is undefined/unsupported.

If a trigger is defined, enter the size of the pre-buffer in percent in the Position (percent) field. If no
trigger is defined, the trigger happens directly when the logging is enabled.
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4. To save the signal configuration file, select Save or Load to load a previously saved file.

5. Select OK to close the Configure Signal Logger window.

6. To log the sampling, select Start Logging in the Signal Logger toolbar.

The logging process is shown in the lower left of the Signal Logger window.

The status for logging is set to Ready. If no trigger events are defined, the status changes to Sampling in

progress. After finishing reading the data in the buffer, the status changes to Complete, indicating that
the logging is completed.
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Logging statuses

Item Description

Off/Ready The logger is disabled and no data is available in the buffer

Init The logger is enabled and applying the configuration

Waiting for trigger The logger is enabled and capturing pre-buffer data frames while waiting for
a trigger condition to happen

Sampling in progress The logger is enabled and are capturing data frames after a trigger condition
has happen.

Complete The logger is disabled, and the buffer contains data. The buffer is either full or
the sampling duration time is reached or the logger has been stopped.

Configuration error The logger is disabled because the configuration settings was not valid

Signals are displayed on a Y- and X-axis graph. To configure the appearance of the signals on the graph,
go to Options in the toolbar.

Graph settings

Item Description

Points Display signal values as points on the graph.

Stairs Display signal values as stairs on the graph.

Auto Y-Axis Automatically scale the Y-axis for all signals.

Min Y-axis Minimum scale value for Y-axis.

Max Y-axis Maximum scale value for Y-axis.

Graph orientation

Left All signals have a common left Y-axis.

Left and Right First signal is attached to the left Y-axis and all other signals are attached to
the right Y-axis.

Vertical split Each signal gets its own swim lane.

You can enable and disable signals on the graph to make them visible or invisible by clicking the
checkboxes in the text legend.

It is also possible to change which axis the signals are attached to, or to display all signals with their own
swim lane.
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PLUS+1® Service Tool settings options

Use PLUS+1® Service Tool settings to access general and advanced page setting options. In the main
menu bar select Options > Settings to open the Options window.

General

Use the General settings screen to set Tool Key, setup screen display, PLUS+1® Service Tool background
color, and Export Log options.
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General settings options

Theme Use to select light or dark appearance in user interface.

Toolbar icon size Use to select icon size displayed in tool bar.

Tool language Select PLUS+1® Service Tool language.

Show the Start Page when no Service

Application is open

Select check box to display the start page when no Service Application is
open.

Automatically use Tool Key from

Service Application files

Select check box to always use the tool key embedded in the *.P1D file.

Automatically scan for Service

Application File

Select to automatically scan for service application files after automatic
system scan is completed.

Enable baudrate setting in status bar Select to enable manual baudrate setting.

Create backup file when overwriting

Service Application files

Select check box to automatically create a *.P1D backup file.

Startup screen delay Enter time that startup screen will be display at start up.

Export log file Select to choose delimiter for log file export. The default is Windows

Advanced Screen

In the Advanced Page Design - Settings select Display tooltip on components and Display help cursor

on help enabled components cursor options.
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Advanced page setting options

Display tooltip on components Select to enable visible tooltip functionality when mouse is over tool tip
function screen items.

Time to display tooltip(s) The time the tool tip is shown (1 to 60 seconds).

Display help cursor on help
enabled components

Select to display help cursor hand image when mouse is over help enabled
components.
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File association

File association setting options

Check at startup if this version... If checked, will check at startup if this version of PLUS+1® Service Tool is
the default associated application for P1D, P1H, and LHX file extensions.

Open Service Applications in... Whether to open Service Applications in an existing instance, or in a new
instance.

File download

Use the File Download setting to select either to always display a parameter settings message or to only
display a message when downloading a file.
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Warnings

Check box to display a warning message if opening a P1D/P1H file with an older file format.

Common settings

Settings common for the PLUS+1 GUIDE, PLUS+1 Service Tool and PLUS+1 Update Center.

User Manual

PLUS+1® Service Tool

Working in normal view

 

© Danfoss | January 2024 AQ152986484649en-001701 | 81



Common settings options

Use custom MyDocuments folder If checked the custom MyDocuments folder will be used.

Browse Browse can be used to select the custom folder path if the checkbox is
checked.
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Use the CAN Monitor to monitor all CAN bus messages and bus load. Messages are displayed in either
decimal or hexadecimal format and can be logged to a file.

CAN Monitor is a basic general-purpose CAN bus log tool, it is not a substitute for a full-scale CAN
analyzer tool.

To use the CAN Monitor you need to have an Express or Professional license installed in the License
Manager.

Monitor CAN bus messages and bus load

1. Select menu item Tools > CAN Monitor

The PLUS+1® CAN Monitor is a standalone window that can be used along side the PLUS+1® Service
Tool.

Tool Bar buttons

Start Start monitoring the CAN bus.

Stop Stop monitoring the CAN bus.

Log to file Log all CAN bus messages to file. The current settings will be applied to the
file content.

Options Open the Options dialog.

Close Close the CAN Monitor window.

CAN messages in main log panel

Chn Active channel ID in the PLUS+1® Service Tool.

Identifier CAN message identifier.
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CAN messages in main log panel (continued)

Flg CAN message flag, empty for standard CAN messages, X for extended.

DLC Data length code, the amount of data bytes in the message.

D...
0...1...2...3...4...5...6...D...7

The content in the CAN message data bytes.

Time The CAN message time stamp, displayed in seconds since the logging was started.

Dir The CAN message direction R, when received by the PLUS+1® Service Tool and T
when sent from the PLUS+1® Service Tool.

The status bar shows the current bus load.

2. Right-click the main panel to show a menu where you can switch to Fixed Positions mode, (for more
information, see Options on page 85), copy the logged content to clipboard and clear the log
window.
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Options

Press the Options button  to display the Options dialog.

General options

Option Description

Numeric base Select decimal or hexadecimal format.

Fixed Positions Check option to enable Fixed Positions mode. In this mode, each CAN ID will be
displayed on a single line and change the content each time a message with the
same CAN ID is received/sent.

Maximum number of lines Select the maximum number of lines of CAN messages displayed.

Font Select font for the CAN message data.

User Manual

PLUS+1® Service Tool

Monitoring the CAN bus

 

© Danfoss | January 2024 AQ152986484649en-001701 | 85



Pass filter options

Enable CAN ID pass filter Check option to enable the pass filter

Lower limit Lower limit of CAN message ID’s that shall pass the filter.

Upper limit Upper limit of CAN message ID’s that shall pass the filter.

Lower and Upper limits can be entered in either decimal or hexadecimal (for example ‘$FF’ or ‘0xFF’)

format.
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Use the PLUS+1® Service Tool command line interface to perform tasks, such as testing a continuous
integration (CI) build agent.

P1Diagnostics

The executable is named P1Diag.exe and it can be found in the /P1Tools/P1Diagnostics
installation folder.

P1Diag can be run in 3 modes: GUI, CLI and GUI+CLI.

EXE modes

Modes Description

GUI PLUS+1® Service Tool will provide a standard Windows
desktop user interface.

CLI PLUS+1® Service Tool will provide a command line
interface, without graphical elements.

GUI+CLI PLUS+1® Service Tool will provide a combined interface
where information will be provided both in the graphical
and the command line interfaces.

Command, Configuration, and Command Modifier Parameters

Command Parameters

Name Description

-run-script <P1J file> <Script function> Run the specified script function and then terminate.
This command requires exactly two parameters, a P1J
file and a script function.
If the script is run successfully, then the exit code will be
zero (0).
Otherwise, the exit code will be one (1).

-download-file-to-ecu <Application file> Download the specified file to the connected system and
then terminate.
The application(s) will automatically be matched to the
available ECU(s). No attempt to download any file will be
done unless the mapping is clear.
This command requires exactly 1 application download
file.
If file download succeeds, then the exit code will be zero
(0).
Otherwise, the exit code will be one (1).

-decrypt-p1t <P1T file> <Decrypted output file> Decrypt the P1T file and then terminate.

This command requires exactly 2 parameters, a P1J file

and a CSV/JSON output file.

If the decryption succeeds, then the exit code will be zero
(0).
Otherwise, the exit code will be one (1).

-create-p1t <Decrypted input file> <P1T file> Create a P1T file and then terminate.

This command requires exactly 2 parameters, a CSV/

JSON input file and a P1T output file name.

If the creation succeeds, then the exit code will be zero
(0).
Otherwise, the exit code will be one (1).
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Command Parameters (continued)

Name Description

-export-p1log-to-csv <Input file> <Output file> Export the specified P1log/LDF file to CSV format and

then terminate.
This command requires exactly 2 parameters, a P1log or

LDF file and a CSV output file.

If the export succeeds, then the exit code will be zero (0).
Otherwise, the exit code will be one (1).

-extract-application-xml <Input p1d file> <Output path> Extracts the application file from the specified p1d file to
xml format.
This command requires exactly 2 parameters, a P1D file

and a output path where the application XML file is

stored.
If the export succeeds, then the exit code will be zero (0).
Otherwise, the exit code will be one (1).

--version Prints the PLUS+1® Service Tool version.
Must not be combined with any other parameter.

/?--help Prints information about CLI usage.
Must not be combined with any other parameter.

Configuration Parameters

Name Description

-use-gateway <Gateway name> Specifies which gateway to select when starting the PLUS
+1® Service Tool.

-use-channel <Channel name> Specifies which gateway channel to select when starting
the PLUS+1® Service Tool.

-use-baudrate <Baud rate> Starts the PLUS+1® Service Tool in normal view.

-normal-view Starts the PLUS+1® Service Tool in normal view.

-design-view Starts the PLUS+1® Service Tool in design view.

-online-mode Starts the PLUS+1® Service Tool in online mode.

-offline-mode Starts the PLUS+1® Service Tool in offline mode.

Command Modifier Parameters

Name Description

-headless Run the PLUS+1® Service Tool in CLI mode only.
Can only be used in combination with a command.

-keep-cli The CLI window will not be hidden.
May be used in combination with a command, or just a
Service Application file.

-silent Run the PLUS+1® Service Tool in silent mode.
In silent mode, the PLUS+1® Service Tool will not output
to stdout.
May be used in combination with a command, or -keep-
cli.

-very-silent Run the PLUS+1® Service Tool in very silent mode.
In very silent mode, the PLUS+1® Service Tool will not
output to either stdout or stderr.
Should normally only be used in combination with -
headless.

Examples

Download a file to ECU from command line:
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"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless -download-file-to-ecu “C:\Projects\DownloadPackage.mlhx”

Run a script function from command line (Add-On license required: 'ST_Pro'*):

"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless -run-script “C:\Projects\ScriptFunctions.p1j” “MyScriptFunction”

Decrypt a P1T file from command line:

"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless -decrypt-p1t “C:\Projects\EcuParameterTransferFile.p1t” “C:
\Projects\DecryptedTransferFile.json”

Create a P1T file from command line:

"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless -create-p1t

“C:\Projects\DecryptedTransferFile.json” “C:\Projects
\EcuParameterTransferFile.p1t”

Export a P1log file to CSV from command line:

"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless -export-p1log-to-csv “C:\Projects\MachineLogFile.p1log” “C:
\Projects\MachineLogFile.csv”

Use a specific gateway, channel and baud rate:

"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics
\P1Diag.exe"-headless <command> -use-gateway "CG150" -use-channel "CG150 #0 (Channel 0)" -use-

baudrate “250000”
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Menu descriptions

Menu bar

Menu bar description

File Use the commands in this menu to create, open, save, scan for and download service
application file.

Edit

View Use the commands in this menu to select and change the PLUS+1® Service Tool on-
screen environment.

System

Design Use the commands in this menu to design, create and modify log and parameter
functions in the PLUS+1® Service Tool.

Parameter Use the commands in this menu to read and write parameter values to the PLUS+1®

GUIDE and generate parameter reports.

Communication Use the commands in this menu to select online or offline modes and Toolbar settings.

Options Use the commands in this menu to select system scan settings, access the Tool Key
dialog box and select background color and startup screen delay settings.

Tools Use the command in this menu to access License Manager.

Help Use the command in this menu to access help and information about the PLUS+1®

Service Tool.

File menu

File menu description

New Creates a new service application file within the diagnostic navigator tab window.

Open Displays the Open dialog box. Use this dialog box to open existing P1D format
application files.

Open Recent Displays list of five recently opened P1D files for quick access.

Close Closes the current program files to its previously selected file location.

Save Saves the current program files to its previously selected file location. This selection is
disabled in Normal view.

Save As... Displays the Save service application dialog box. Use this dialog box to save current
service application file. This selection is disabled in Normal view.

Scan for Service
Application File...

Displays the Scan Connected System dialog box. The dialog box will automatically scan
for P1D service application files.

User Manual

PLUS+1® Service Tool

Menu bar

 

90 | © Danfoss | January 2024 AQ152986484649en-001701



File menu description (continued)

File Properties... Select the view Service Application file details.

Replace Missing ECU... Select this option for program to scan application for any missing ECU in all log and
parameter functions.

Replace Existing ECU... Select this option for program to scan application for unused ECU available for
replacement in log and parameter functions.

Exit Closes the PLUS+1® Service Tool.

Edit menu

Edit menu description

Find/Replace Signal
Names...

Find, replace or insert signal names in all or part of selected ECUs.

Find Clipped Texts...

Design...

Rename Select this option to rename selected log and parameter functions.

Delete... Select this option to delete log and parameter functions.

Edit Translations...

View menu

View menu description

Run Application Select this option to use the PLUS+1® Service Tool without the log and parameter
design functions.

Design Application Select this option to use the PLUS+1® Service Tool with log and parameter design
functions.

System Navigator Select this option to show or hide the System Navigator.

Default Layout Select this option to use the PLUS+1® Service Tool with all menus and tool bar options
available.

Toolbars Use this dialog box to select tool bar icons to for display in tool bar. Use the tool bar
buttons to quickly access frequently used service and diagnostic functions
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System menu

System menu description

Scan System... Displays the Scan Connected System dialog box. The dialog box will automatically scan
system for connected equipment.

File Download... Displays the Application File Download dialog box. Use this dialog box to download file
programs into the PLUS+1® Service Tool.

Read ECU History... Select to show ECU history in log form.

Manage ECU Media Files...

Read Application Log... Select to read saved application log data.

Decode Application Log
File...

Use to convert application log files into a CSV file format for spreadsheet view.

Recover ECU...

Create System Download
Package...

Design menu

Design menu description

New Log Page Creates a new log function in the diagnostic navigator pane of the PLUS+1® Service
Tool window. Select basic or advanced log design function

New Parameter Page Creates a new parameter function in the diagnostic navigator pane of the PLUS+1®

Service Tool window. Select basic or advanced parameter design function.

Lock File... Select to permanently lock P1D and P1H files.

System Configuration... Define display style, scan options and tooltip information for a selected system.

Tool Key in Service
Application File...

Create a tool key for customized application protection.

Service Application
Properties...
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Parameter menu

Parameter menu description

Read Select Read to read parameter settings from controller to the PLUS+1® Service Tool.

Write Select Write to write parameter settings from the PLUS+1® Service Tool to the
controller.

Set Default Select to reset default parameter values.

File Import... Select to import parameter files.

File Export... Select to export parameter values.

Check write for all
parameters

Choose to select all parameters for writing.

Uncheck write for all
parameters

Choose to unselect all parameters for writing.

Generate Report... Select Generate Report to save parameter report to PLUS+1® Service Tool.

ECU Parameter Transfer Select to read or write parameter values to or from another location.

Communication menu
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Communication menu description

Online Mode Toggle this menu option to work in online mode.

Offline Mode Toggle this menu option to work in offline mode.

Virtual Mode Toggle this menu option to work in virtual mode.

Gateway Select connection device to enable CAN communication and specific channel
selections.

Baudrate Select preferred baudrate (default baudrate is 250k).

Protocols... Select communication protocols.

Start Logging Select this option to begin logging.

Stop Logging Select this option to stop logging.

Change Log Period... Select this option to open Change Log period dialog box. Use this dialog box to change
log frequency (in millisecond increments).

Record to File Record to file.

Open Log File... Use to play saved log file.

Options menu

Options menu description

Tool Key... Use to lock log and parameter files.

Install Diagnostic Data... Select to manually install diagnostic data files.

Language Tool and Service Application language settings.

Settings... Displays the Settings dialog box. Use dialog box to select general and advance screen
settings options.

Tools menu

Tools menu description

CAN Monitor

License Manager Displays the License Manager dialog box. Use this dialog box to add a PLUS+1® Service
Tool, delete a license, activate a license or get a license.

Customize... Use to create custom toolbar button options.
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Help Menu

Help menu description

Help Contents Opens in-application help file.

User Manual Opens PDF User Manual.

Design Manual

Scripting Design Manual

Release Notes Last minute news and notes.

PLUS+1® Online Select to visit the PLUS+1® website.

Support Use Support to access the PLUS+1® support website, create a troubleshooting file for
diagnosis or to open your desktop for PLUS+1® Help desk access.

About PLUS+1® Service
Tool

Select to view PLUS+1® Service Tool and license information.
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Toolbar descriptions

Toolbar

1 New Service Application Creates a new service application file within the diagnostic
navigator tab window.

2 Open Service Application Displays the Open dialog box. Use this dialog box to open
existing P1D format application files.

3 Save Service Application Saves the current program files to its previously selected file
location.

4 File Download Displays the Application File Download dialog box. Use this
dialog box to download file programs into the PLUS+1® Service
Tool.

5 Scan System Displays the Scan Connected System dialog box. The program
will automatically scan system for connected equipment.

6 Run Application / Design Application Switch between design mode and run mode.

7 Read Parameters from ECU Select to read all parameter values from the ECU.

8 Write Parameters to ECU Select to write all parameter values to the ECU.

9 Start Communication / Stop Communication Select to begin logging or stop logging.

10 Record / Stop Recording Select to record a log file, or stop recording and save the log file.

11 Open Log File Open a recorded log file.

12 Baud rate View/change current baud rate.

13 Help View help content.
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Danfoss Power Solutions is a global manufacturer and supplier of high-quality hydraulic and
electric components. We specialize in providing state-of-the-art technology and solutions
that excel in the harsh operating conditions of the mobile off-highway market as well as the
marine sector. Building on our extensive applications expertise, we work closely with you to
ensure exceptional performance for a broad range of applications. We help you and other
customers around the world speed up system development, reduce costs and bring vehicles
and vessels to market faster.

Danfoss Power Solutions – your strongest partner in mobile hydraulics and mobile
electrification.

Go to www.danfoss.com for further product information.

We offer you expert worldwide support for ensuring the best possible solutions for
outstanding performance. And with an extensive network of Global Service Partners, we also
provide you with comprehensive global service for all of our components.

Local address:

Danfoss 
Power Solutions GmbH & Co. OHG
Krokamp 35
D-24539 Neumünster, Germany
Phone: +49 4321 871 0

Danfoss 
Power Solutions ApS
Nordborgvej 81
DK-6430 Nordborg, Denmark
Phone: +45 7488 2222

Danfoss 
Power Solutions (US) Company
2800 East 13th Street
Ames, IA 50010, USA
Phone: +1 515 239 6000

Danfoss 
Power Solutions Trading
(Shanghai) Co., Ltd.
Building #22, No. 1000 Jin Hai Rd
Jin Qiao, Pudong New District
Shanghai, China 201206
Phone: +86 21 2080 6201

Danfoss can accept no responsibility for possible errors in catalogues, brochures and other printed material. Danfoss reserves the right to alter its products without notice. This also applies to products
already on order provided that such alterations can be made without subsequent changes being necessary in specifications already agreed.
All trademarks in this material are property of the respective companies. Danfoss and the Danfoss logotype are trademarks of Danfoss A/S. All rights reserved.
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Products we offer:

• Cartridge valves

• DCV directional control
valves

• Electric converters

• Electric machines

• Electric motors

• Gear motors

• Gear pumps

• Hydraulic integrated
circuits (HICs)

• Hydrostatic motors

• Hydrostatic pumps

• Orbital motors

• PLUS+1® controllers

• PLUS+1® displays

• PLUS+1® joysticks and
pedals

• PLUS+1® operator
interfaces

• PLUS+1® sensors

• PLUS+1® software

• PLUS+1® software services,
support and training

• Position controls and
sensors

• PVG proportional valves

• Steering components and
systems

• Telematics

Hydro-Gear

www.hydro-gear.com

Daikin-Sauer-Danfoss

www.daikin-sauer-danfoss.com 
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