### Table of revisions

<table>
<thead>
<tr>
<th>Date</th>
<th>Changed</th>
<th>Rev</th>
</tr>
</thead>
<tbody>
<tr>
<td>November 2019</td>
<td>Supports 12.0</td>
<td>0901</td>
</tr>
<tr>
<td>April 2019</td>
<td>Supports 11.1</td>
<td>0801</td>
</tr>
<tr>
<td>November 2018</td>
<td>Supports 11.0</td>
<td>0701</td>
</tr>
<tr>
<td>May 2018</td>
<td>Supports 10.1</td>
<td>0601</td>
</tr>
<tr>
<td>October 2017</td>
<td>Supports 10.0</td>
<td>0501</td>
</tr>
<tr>
<td>March 2017</td>
<td>Supports 9.1</td>
<td>0401</td>
</tr>
<tr>
<td>October 2016</td>
<td>Supports 9.0</td>
<td>0301</td>
</tr>
<tr>
<td>August 2015</td>
<td>Supports 7.2.x and later</td>
<td>0200</td>
</tr>
<tr>
<td>October 2014</td>
<td>Supports 7.1.x and later</td>
<td>BA</td>
</tr>
<tr>
<td>September 2014</td>
<td>Conversion to Danfoss layout</td>
<td>AB</td>
</tr>
<tr>
<td>November 2013</td>
<td>First edition</td>
<td>AA</td>
</tr>
</tbody>
</table>
Contents

General information
IEC 61508:2010 support tool certification references ................................................................. 5
Important information to reduce risk ............................................................................................. 5
Fault checking and error handling ................................................................................................. 6
Downloading and testing your applications ................................................................................ 6
Learning about the PLUS+1® Service Tool ................................................................................. 7
Getting ready ................................................................................................................................ 7

PLUS+1® hardware setup
CAN hardware installation .............................................................................................................. 8
CAN hardware installation troubleshooting ..................................................................................... 8
Using the PLUS+1® CG150-2 USB/CAN Gateway Interface Communicator ............................... 9
Using the PLUS+1® DP Series Display USB/CAN gateway .......................................................... 9
Using the PLUS+1® InterLink gateway ........................................................................................ 9
Using the third party Gateway devices via the RP1210 standard .................................................. 10
Connection .................................................................................................................................... 11
Diagnosing gateway warnings and errors using the RP1210 standard ....................................... 11
Using Reset Gateway in advanced settings ................................................................................. 11

Managing protocols
Managing Protocols values .......................................................................................................... 12
Add new protocols ......................................................................................................................... 13
Protocol options ............................................................................................................................ 14

PLUS+1® Service Tool window
Start page ........................................................................................................................................ 16
System Navigator features ........................................................................................................... 17
Locking and unlocking Diagnostic Navigator pane ................................................................. 17
Restoring default layouts ............................................................................................................ 18

PLUS+1® Service Tool languages
Installing tool languages during setup ........................................................................................ 19
Managing languages in PLUS+1® Service Tool .......................................................................... 19
Selecting the PLUS+1® Service Tool language ......................................................................... 19
Selecting the Service Application language .............................................................................. 20

Downloading the application
Preparing to Download the Application File to the Controller ..................................................... 21
Downloading system download packages ...................................................................................... 23
Mandatory applications/missing ECUs .......................................................................................... 24
Retry downloads ............................................................................................................................. 24
Parameter settings during the application download .................................................................... 25
Recover ECU functions ................................................................................................................ 27

Working with service application files
Introduction to service application files ...................................................................................... 29
Log page ....................................................................................................................................... 29
Parameter page ............................................................................................................................. 29
Manual Load of Service Application Files .................................................................................. 29
Scanning for service application files .......................................................................................... 30
Boot loader mode ......................................................................................................................... 31
Automatic scan for service application files .............................................................................. 32
Opening hardware service files ................................................................................................... 33
Manual installation of diagnostic data files ................................................................................... 33

Using log pages
Logging controls ............................................................................................................................. 36
Saving log files ............................................................................................................................. 37
Monitor log files .......................................................................................................................... 38
Log file playback ......................................................................................................................... 39
Log file process ............................................................................................................................ 39
Exporting log files to spreadsheet .............................................................................................. 40
Contents

Using parameter pages
Manual parameter upload and download................................................................. 42
Selecting parameter for download........................................................................ 42
Importing parameter values.................................................................................... 43
Automatic parameter upload function................................................................. 43
Parameter upload and download error messages.................................................. 43
Parameter file export............................................................................................... 44
Parameter file import.............................................................................................. 45
Generating parameter reports............................................................................... 46
Parameter memory transfer.................................................................................... 47
Upload parameter values...................................................................................... 47
Download parameter values.................................................................................. 48
Decrypting P1T files............................................................................................... 49
Creating P1T files................................................................................................. 51

Using contextual help in service applications
Contextual help feature.......................................................................................... 53

Using the Tool Key
Tool Key function.................................................................................................... 54
Set up Tool Key information.................................................................................... 54
Manually entered Tool Key set up.......................................................................... 55
License embedded Tool Key set up........................................................................ 56

Working in normal view
Application log........................................................................................................ 57
Application log file................................................................................................. 57
PLUS+1® Service Tool settings options.................................................................. 59

Monitoring the CAN bus
Monitor CAN bus messages and bus load.......................................................... 63
Options................................................................................................................... 65

PLUS+1® Service Tool command line mode
Command, Configuration, and Command Modifier Parameters............................ 67

Menu bar
Menu descriptions................................................................................................... 70

Toolbar
Toolbar descriptions............................................................................................... 77
General information

IEC 61508:2010 support tool certification references

Contact and reference material are available regarding which versions of PLUS+1® Service Tool carry the IEC 61508:2010 support tool certification.

Please contact the PLUS+1® Helpdesk.


For complete details regarding PLUS+1® GUIDE and PLUS+1® Service Tool IEC 61508:2010 support tool certificates, see:

PLUS+1® GUIDE User Manual, AQ00000026
https://www.danfoss.com/en/search/?filter=type%3Adocumentation%2Csegment%3Adps

Important information to reduce risk

Your responsibility when designing a PLUS+1® Service Tool application is to include the checking and the error handling needed to reduce risks in normal and abnormal operating conditions.

The applications that you create with the PLUS+1® Service Tool typically control heavy, powerful, and mobile off-road equipment such as tractors, cranes, and harvesters.

The PLUS+1® Service Tool has no automatic protections against the risks, such as from bugs in the PLUS+1® Service Tool software, errors in the PLUS+1® Service Tool user guides, or incompatibilities between software versions of the PLUS+1® Service Tool.

You must design and test your application to reduce these risks.
General information

Fault checking and error handling

The following are some items to consider when developing fault checking and error handling for your application.

Consider:

• How the machine is normally used
• Possible operator errors and their consequences
• Industry safety standards and legal requirements
• Input and output failures and their consequences including:
  – Joystick, sensor, and other inputs suddenly going to 100 % or to 0 %
  – Outputs that control machinery direction, speed, and force suddenly changing direction or going to 100 % or to 0 %
• Decide how likely each failure is
  – The more likely a failure, the more you need protect against the consequences of the failure
• The sequence of events and consequences of a fault or error
• The sequence of events and consequences of an emergency stop

⚠️ Warning
Under normal operating conditions, using this type of machinery always involves risk of personal injury and equipment damage. Abnormal operating conditions increase the risk of personal injury and equipment damage.

Downloading and testing your applications

Once you have created an application, you have the responsibility to download and test the application. You should only download your application to hardware or change software parameters while the vehicle is not in operation. After downloading, test application operation under normal and abnormal operating conditions.

You should make sure that:

• Individual inputs produce expected outputs.
• Combinations of inputs do not produce unexpected or dangerous outputs.
• Fault handling and error checking work as designed.
Learning about the PLUS+1® Service Tool

After successfully creating your first controller application using the PLUS+1® GUIDE, you need to put it to use now. Use the PLUS+1® Service Tool to:
• Download an application to a controller
• Log and tune controller performance
• Download parameters to a controller

This manual will help you to understand the following concepts and processes:
• The overall concept of the PLUS+1® Service Tool
• How to download an application file to a controller application
• How to run log pages
• How to change controller parameters

Getting ready

Individual requirements to work with the applications in this manual:
• Fully functional versions of the PLUS+1® GUIDE and PLUS+1® Service Tool programs installed on PC
• A completed controller application to use within the PLUS+1® Service Tool
• The following hardware to download these controller applications:
  – One PLUS+1® CG150-2 or PLUS+1® DP series display (or a similar third party CAN communication device)
  – One 12 to 24 VDC 55 mA power supply
• Working knowledge of the PLUS+1® GUIDE environment, including an understanding to use the full capabilities of the PLUS+1® Service Tool

Proper hardware has be to connected and installed on a computer before you can use the PLUS+1® Service Tool. Connect the controller to the CAN communication device.

The graphical images in this manual may appear slightly different, depending on which version of the PLUS+1® Service Tool is in use.
PLUS+1® hardware setup

CAN hardware installation

It is necessary to install CAN driver software before using the PLUS+1® Service Tool.

1. Plug in the PLUS+1® CG150-2 USB cable to the PC USB port. The Hardware Wizard searches for and installs CAN software. This may take several minutes.

2. Click Close to close the Driver Software Installation dialog.

The following message appears when installation is complete.

USB drivers can be found in the directory: <Program Files>\Danfoss\PLUS1\<Service Tool Version>\Misc\.

CAN hardware installation troubleshooting

To resolve issues related to the Danfoss PLUS+1® CG150-2 CAN/USB gateway interface communicator, perform the following procedure:

1. Close the PLUS+1® Service Tool.
2. Enter the Device Manager in Windows® operating system by selecting: Control Panel > System > Device Manager.
3. Select PLUS+1® CG150-2 or PLUS+1® Display under the Danfoss > Device Manager.
4. Right-click Danfoss CG150-2 or Display and select Uninstall.
 PLUS+1® hardware setup

5. Ensure that the **Delete the driver software for this device** option is unchecked, then click **OK**.

![Delete driver software for this device](image)

6. Unplug the PLUS+1® CG150-2 then plug it back into PC USB port.

The **Found New Hardware** balloon should appear in the Windows® taskbar. Complete the driver installation wizard and start the PLUS+1® Service Tool to re-establish connection with the PLUS+1® CG150-2.

**Using the PLUS+1® CG150-2 USB/CAN Gateway Interface Communicator**

Select **Communication > Gateway > CG150-2** from the PLUS+1® Service Tool window menu.

![Gateway CG150-2](image)

**Using the PLUS+1® DP Series Display USB/CAN gateway**

PLUS+1® DP Series Displays with USB connectivity can be used as a CAN gateway.

Make sure that the display is connected using a supported USB cable (see product documentation).

Select **Communication > Gateway > Enable** from the PLUS+1® Service Tool window menu.

![Gateway Enable](image)

**Diagnose** will be a choice under **Gateway** to select to examine any detected errors and warnings.

**Using the PLUS+1® InterLink gateway**

PLUS+1® products with PLUS+1® InterLink capabilities can be used as a gateway.

Make sure that the device is accessible through Wi-Fi/Ethernet/Bluetooth/USB (see product documentation).

Select **Communication > Gateway > PLUS+1 InterLink** from the PLUS+1® Service Tool window menu.
PLUS+1® hardware setup

The PLUS+1® Service Tool will search for available PLUS+1® InterLink devices, and these devices will be available as channels.

After selecting the desired channel, a **Gateway Password** dialog will show up if the gateway is password protected. Enter the correct password and press the **Connect** button to connect. Check the **Remember password** check box to save the password.

**Using the third party Gateway devices via the RP1210 standard**

The PLUS+1® Service Tool supports the generic communication standards RP1210B & RP1210A for any compliant third party gateway. These recommended practice standards were written by the Technology and Maintenance Council (TMC).

- **RP1210B** gateways may not support all baudrates that the built-in gateways support.
  - RP1210B gateways can be used if they support the generic CAN protocol.
- **RP1210A** gateways only supports baudrates equal to 250k.
  - RP1210A gateways can be used if they:
PLUS+1° hardware setup

- Support the generic CAN protocol
- Support blocking calls
- Use the same endianness (byte order) for CAN messages as RP1210B

• Activate RP1210 gateways by selecting the appropriate DeviceID in the submenu under the gateway submenu. All possible device IDs will be listed for selection. Devices do not need to be connected to the computer to be listed.

Connection

When an RP1210B or RP1210A gateway has been properly installed, it will be automatically added to the list of installed gateways under Communication > Gateway after the PLUS+1° Service Tool is restarted.

The name of the new gateway consists of the name of the standard implemented (RP1210B or RP1210A) plus the name of the gateway vendor as written in the vendor supplied .ini file. The order of gateways in the list is determined by the global RP121032.ini file.

Diagnosing gateway warnings and errors using the RP1210 standard

Configure an RP1210 gateway using its .ini file. It is important that the .ini file follows the standard.

If the PLUS+1° Service Tool has problems reading the .ini file, an error or a warning message will occur. If an error is found, it will not be possible to use the gateway from the PLUS+1° Service Tool. If warnings are found it will still be possible to use the gateway, but a communication slowdown will occur. This slowdown can be overridden by the user. See Using Reset Gateway in advanced settings on page 11 to fix a gateway error manually.

Diagnose will be a choice under Gateway to select to examine any detected errors and warnings.

Advanced users may wish to use the View RP1210 parse log to troubleshoot RP1210 gateways that may not be working well with the PLUS+1° Service Tool.

Select Communication > Gateway > Advanced > RP1210 Log from the PLUS+1° Service Tool window menu.

The contents shown in the RP1210 Parse Results window is generated from the code and never stored in a specific file.

A gateway that does not implement RP1210B, but only RP1210A will generate a warning message.

Using Reset Gateway in advanced settings

Reset Gateway can be used to:

• Search for gateway changes
• Manually fix a gateway error that is not automatically detected
Managing protocols

Managing Protocols values

Protocols must be installed and selected before they can be used. This can be done in the Manage Protocols window. More than one protocol can be used at a time.

The PLUS+1® Service Tool also supports the use of communication protocols other than the standard PLUS+1® protocol, but not all PLUS+1® features may be functional if a different protocol is used.

To manage communication protocols, select: Communication > Protocols....

This opens the Manage Protocols window, see below:

Selecting Add Protocol opens the window, where all installed protocols can be seen and managed. The Manage Protocols window displays the following values:

### Manage Protocols Values

<table>
<thead>
<tr>
<th>ID</th>
<th>All protocols have an assigned ID number from 0 to 255. PLUS+1® protocol is always 0 and Virtual is always 255.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Protocol name.</td>
</tr>
<tr>
<td>DLL Path</td>
<td>Location folder of actual DLL file.</td>
</tr>
<tr>
<td>Data Path</td>
<td>Location of a created folder where protocol-related information can be stored. This location can be changed by the user.</td>
</tr>
<tr>
<td>Active Selection Box</td>
<td>Check box checked: protocol is active.</td>
</tr>
<tr>
<td>Remove</td>
<td>Link to remove protocol from system.</td>
</tr>
</tbody>
</table>
Managing protocols

Add new protocols

1. Add new protocols by clicking the **Add Protocol** button in the lower left corner of the Manage Protocols window.

2. Select a protocol DLL in the Select Protocol DLL dialog and click **Select** to confirm the choice.

   The added protocol will now appear in the protocols list of the Manage Protocols window with an assigned ID number.

3. Use the **Manage Protocols** window to check data path, activate, remove or modify options for the protocol. When finished, click **OK**.

   The protocol is added and ready for use.

When using multiple protocols in a system, make sure that the protocols will not interfere with each other. High bus load may occur when using many protocols at the same time.
Managing protocols

Protocol options

Protocol option values can be changed. In the Manage Protocols window, select a protocol in the list to view the protocol options displayed in the bottom part of the dialog. The options and information for each protocol will vary.

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>KP0000_Therm</td>
<td>U8</td>
<td>Use the setting to avoid dropping CAN frames when using a slow gateway. Slower gateways...</td>
<td>0</td>
</tr>
<tr>
<td>KP0000_BlinkOn</td>
<td>U16</td>
<td>See 323-0770-2 for specification on SD (BlinkOn).</td>
<td>0</td>
</tr>
<tr>
<td>SystemStatusInterval</td>
<td>RANGE 10..1000</td>
<td>Determines how often (in ms) the PLUS+1 system is polled. A low value means a high load...</td>
<td>900</td>
</tr>
<tr>
<td>DP1220_filter</td>
<td>ROOL</td>
<td>Determine if CAN filter shall be enabled when using a DP1220 gateway. Only CAN messages...</td>
<td>0</td>
</tr>
<tr>
<td>KP0000_A4STimeOut</td>
<td>U16</td>
<td>Extends the receive timeout value (in ms). Slower gateways need longer delays.</td>
<td>0</td>
</tr>
</tbody>
</table>

Options for protocol window

- **Name**: The name of the option.
- **Type**: Setting type.
- **Description**: A short description of the setting.
- **Value**: The current value of the setting.
- **Edit**: The editable properties of the setting. If field is empty, the setting is not editable (see editing properties for more information).

Click the value in the **Edit** field to edit the option value. Click **OK** to save and use the updated option values.
### PLUS+1® Service Tool Window Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Menu bar</td>
<td>Use to access PLUS+1® Service Tool commands and information.</td>
</tr>
<tr>
<td>2.</td>
<td>Toolbar</td>
<td>Use to access common PLUS+1® Service Tool commands and information.</td>
</tr>
<tr>
<td>3.</td>
<td>System Navigator</td>
<td>Use to show a tree view of all hardware and software applications within the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>4.</td>
<td>Work area</td>
<td>The area where all PLUS+1® Service Tool functions are performed.</td>
</tr>
<tr>
<td>5.</td>
<td>Service function status</td>
<td>Displays information of current PLUS+1® Service Tool function.</td>
</tr>
</tbody>
</table>
| 6.     | Controller connection status  | • Green — Controller connected  
          | • Blue — Logging or Downloading  
          | • Yellow — Searching for connection  
          | • Red — Controller disconnected or gateway error |
| 7.     | Log period status             | Displays the requested and actual log period settings in the application.   |
| 8.     | CAN device information        | Displays connected CAN/USB gateway interface communicator information.     |
| 9.     | CAN baudrate                  | Displays the baudrate setting for the CAN/USB gateway interface communicator. |
The start page is available by default when no Service Application is open in PLUS+1® Service Tool. It can be disabled in Options under General (or new page number if changed).

### PLUS+1 Service Tool start page

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Download…</td>
<td>Displays the Open Download File dialog. Once a file is selected, the Download File dialog is displayed.</td>
</tr>
<tr>
<td>New Service Application</td>
<td>Creates a new empty Service Application.</td>
</tr>
<tr>
<td>Open Service Application…</td>
<td>Displays the Open Service Application dialog. Use this dialog to locate and open Service Application files.</td>
</tr>
<tr>
<td>Recent Service Applications</td>
<td>A list of recently opened Service Applications. Select a Service Application to open from this list.</td>
</tr>
<tr>
<td>Bookmarked Service Applications</td>
<td>A list of bookmarked Service Applications. Select a Service Application to open from this list.</td>
</tr>
<tr>
<td>Tutorials</td>
<td>A list of tutorial links into the HTML version of the user and design manuals.</td>
</tr>
<tr>
<td>Update Center</td>
<td>Shortcut to start the PLUS+1® Update Center.</td>
</tr>
<tr>
<td>PLUS+1® Forum</td>
<td>Shortcut to the PLUS+1® Forum online.</td>
</tr>
<tr>
<td>PLUS+1® Channel</td>
<td>Shortcut to the PLUS+1R YouTube channel.</td>
</tr>
<tr>
<td>Helpdesk Support</td>
<td>Contact information to PLUS+1® Helpdesk.</td>
</tr>
</tbody>
</table>
PLUS+1® Service Tool window

System Navigator features

The System Navigator section of the PLUS+1® Service Tool window contains and displays important information for the PLUS+1® Service Tool.

It is possible to copy the ECU list information to the clipboard, by right-clicking the ECU List node and selecting the menu item Copy ECU List to clipboard.

The System Navigator area is the starting point for all PLUS+1® Service Tool functions.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Use the System Navigator to:

- Set and display system information
- Store and access documents (right click on Documents icon to add, remove or hide documents in Normal view)
- Set and display ECU information
- Display Net, node and hardware information
- Create, open and arrange Log and Parameter pages
- Store and display PLUS+1® Service Tool activity history

Information in the System Navigator is arranged in a hierarchical style. Sections can be expanded or minimized as needed.

Locking and unlocking Diagnostic Navigator pane

Unlock the Diagnostic Navigator pane

1. Drag the pane by the undocking bar to separate it from the main window.

Drag to unlock (docked)

Lock the Diagnostic Navigator pane
PLUS+1 Service Tool window

2. Double-click on the title bar at the top of the window.
   The Navigator pane snaps to its default position.

   Double-click to dock (undocked)

Hide the Diagnostic Navigator pane

3. Toggle either the Diagnostic Navigator button on the toolbar or Diagnostic Navigator in the View menu.
Display the Diagnostic Navigator pane

4. Move the mouse cursor to the left side of the PLUS+1 Service Tool window or click the System Navigator button on the toolbar again.

Restoring default layouts

Select View > Default Layout to restore the PLUS+1 Service Tool window settings to the default layout.
Installing tool languages during setup

When setting up the PLUS+1® Service Tool, install additional languages in the Select Languages page.

Managing languages in PLUS+1® Service Tool

1. In the PLUS+1® Service Tool, select Tools > Language > Language Manager.
2. Select language to install or uninstall.
   You cannot uninstall the default language (English).

Selecting the PLUS+1® Service Tool language

To select the preferred PLUS+1® Service Tool language, select Tools > Language > Select Language.

Alternatively, you can use the drop-down list in the toolbar.
To select the default language (English), select Tools > Language > Default Tool Language. This can also be done by selecting Ctrl+Alt+F.

Selecting the Service Application language

When a multilingual Service Application is active and the tool is in Normal View, select Tools > Language > Select Service Application Language.

Alternatively, you can select the preferred language in the drop-down list of the toolbar.
Preparing to Download the Application File to the Controller

1. Click the **File Download** button in the PLUS+1® Service Tool window toolbar. This can also be done by selecting **File > File Download** or Ctrl+D command.

2. Browse in the **Open** dialog box and click the file name of your application, then click **Open**. It is possible to select multiple download files.

3. Select the target ECU in the **ECU dropdown** menu and click **Next**.

The download file is now ready for downloading.

4. Check the **Show report after download** checkbox to get a report of the download.

It is possible to configure the PLUS+1® Service Tool to automatically save download reports to a specific folder. If this functionality is enabled, the **Show report after download** checkbox will not be available.
5. Click **Start Download** to download the application.
Downloading the application

A progress bar is shown while downloading

It is recommended that there are no other applications running on your PC while downloading the application file. This will speed the file transfer process up and help to avoid possible system and application conflicts.

Caution

To avoid possible system and application conflicts, do not disconnect or power off the system during the download process. The PLUS+1® Service Tool will automatically rescan the controller when the download is completed.

- If the target OS version does not match the file OS version when attempting to download, a warning message will be shown in the Application File Information in the Download File to ECU window:

![Warning message]

![Warning message]

- If the target application file type does not match the file application type for the file that is to be downloaded, a warning message dialog box will appear:

![Warning message dialog box]

When the download is completed, the application is ready for testing.

6. Click the **Save Report** button when the download is finished to create a report file.

Downloading system download packages

When using system download packages, there will be a list of individual downloads (1-∞) in the list. It is possible to check/uncheck individual downloads, depending if they are mandatory or not.
1. Click **Next** to see eventual parameter settings.
2. Click **Start Download** to start all downloads.

**Mandatory applications/missing ECUs**

Applications might be mandatory in a package. It is not possible to deselect these applications during the download sequence.

If no valid ECU is found for the mandatory application, it will not be possible to continue the system download.

**Retry downloads**

It is possible to retry a failed download. The successful downloads will be unchecked by default, and the failed download will remain checked.
Downloading the application

Press the **Retry Download** button to retry the failed downloads.

Parameter settings during the application download

**Parameter Settings - Values** dialog window will appear when downloading applications with common parameters.

- The upper field shows information about the current application and the application to be downloaded.
- The lower field shows changes in the parameter structure.

The **Status icons** display more detailed information about the parameter. Only parameter values that are checked in the Parameter Values dialog box will be downloaded during file download.
If restricted parameters exist, a warning message will be displayed.

- Restricted parameters will be transferred automatically.
- New restricted parameters will be set to zero.
- Restricted parameters with changed parameter type will be transferred if the value is valid within the new parameter type; otherwise the parameter value will be set to zero.

Use the Parameter Setting pull-down selection to define parameter setting behavior:

- **Automatic** selection will transfer values where the memory locations have been changed.
- **Set to Zero** will set all parameter values to zero (parameter values with restricted access will be transferred to the new application).
- **User Defined** is automatically selected when custom changes are made. All fields that are white (not grey) are possible to change manually

An option is available whether to always display the parameter settings dialog, or only when the parameter structure is changed.
The correct Tool Key for the current application must be supplied before the download to be able to transfer the parameter values automatically. If not, a warning dialog will be displayed. If you continue the download, parameter values will not be transferred to the new application.

Recover ECU functions

The Recover ECU is now available for all protocols (where supported), and not only the PLUS+1® protocol. A protocol field has been added to the Recover ECU dialog.
Downloading the application

It is also possible to install diagnostic data files for all protocols (where supported).

To use the Recover ECU functionality with a display or RP1210 gateway it is required to have at least 3 units attached to the CAN Bus: The diagnostic interface, the ECU to recover, and at least one hardware that can do acknowledge on the CAN messages sent by the PLUS+1® Service Tool.
Working with service application files

Introduction to service application files

In order to interface with an ECU application, a service application file is needed. Service application files can contain both Log and Parameter pages.

There are two ways to open service application files in the PLUS+1® Service Tool application.
• Manual load service application files
• Scan for service application files

Log page

Use the Log page to:
• Monitor application activity
• Enable data logging to file
• Export log data to Microsoft Excel®

Parameter page

Use the Parameter page to:
• Download and upload PLUS+1® GUIDE profiles and parameters
• Import and export created parameter files
• Generate database reports of parameter values

Manual Load of Service Application Files

1. Select File > Open

<table>
<thead>
<tr>
<th>File</th>
<th>View</th>
<th>Design</th>
<th>Log</th>
<th>Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open...</td>
<td>Ctrl+O</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save As...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Working with service application files

2. Select System Application files to load to the System Navigator.

Scanning for service application files

Use **Scan for Service Application File...** to load service application files:

1. Select **File > Scan for Service Application File...**

If the connected system contains a System ID, that System ID will be used to find matching service application files. All service application files that contain an exact matching System ID will be displayed in the results dialog.

If only one matching file is found, this file will be opened automatically. Matching files are added to the list while searching.
Working with service application files

2. To open a matching file and close the search dialog, select the desired file in the list and select **Open**.

Refer to the **PLUS+1® GUIDE User Manual, 10100824** for instructions how to enter System IDs into **PLUS+1® GUIDE**.

The PLUS+1® Service Tool will search for service application files in the following locations:

- Any service application file that has been previously opened
- Files in the **My Documents Danfoss\PLUS1\GUIDE Service Tool\Service Application Files Folder**

If no System ID is available in the connected system, files will be matched using the Net/Node Number, Application ID, and Application Type of the file and connected system. An exact match of all ECUs in the file and system is required.

**Boot loader mode**

After downloading an application, the system is scanned for new diagnostic data to load.

If the connection is broken during the application download, the ECU will go into boot loader mode.
Working with service application files

When the ECU is in boot loader mode the ECU will be displayed red in the System Navigator.

Downloading a valid application will take the ECU out of boot loader mode.

Automatic scan for service application files

The PLUS+1 Service Tool can be set to automatically open the correct P1D after scanning the system in normal view.

The option **Automatically scan for Service Application File** must be enabled in the PLUS+1 Service Tool settings for this feature to be active.

When enabled, the **Scan for Service Application File** function on the File Menu will be activated after each system scan.

1. Enable the feature by selecting **Automatically scan for Service Application File** in the General section of the Options dialog box.
Working with service application files

2. Click **OK** to save your selection and close the Options dialog box.

The **Automatically Scan for Service Application File** will only be activated if the connected system contains a System ID.

Opening hardware service files

There are two ways to open hardware service files in the PLUS+1® Service Tool application:

- The PLUS+1® Service Tool can scan for hardware service files
- Files can be manually loaded

1. Open the PLUS+1® Service Tool.
2. In the System Navigator, right-click on the ECU and select option:
   - **Scan for Hardware Service File...**
   - **Load Hardware Service File...**

Manual installation of diagnostic data files

In the PLUS+1® Service Tool, diagnostic data files are automatically installed when a P1H/P1D or LHX file is opened.
Diagnostic data files can also be installed manually by selecting File > Install Diagnostic Data.

1. Click Install Diagnostic Data...
   Active communication protocols that support Install Diagnostic Data files are listed.

2. Select from the list of active protocols to display the installed diagnostic data files.
3. Select a data file to install or uninstall.
   A new file can be added by leaving all selections unchecked and clicking Install.
Working with service application files

4. After clicking install, select a file to install from the Open window. Click Open to install.

An installation dialog window will confirm the status of the file installation. Unsuccessful installations will be shown in red with the reason for the failed installation.
Using log pages

Logging controls

1. In the menu bar of the main PLUS+1® Service Tool window, select Log > Start Logging to begin log activity.

2. To stop logging, select Log > Stop Logging.

3. Logging can be monitored in any or all of the four log file views chosen in the Design Diagnostic Page. Click through the tabs to change log views.

4. Logging controls can also be accessed through the button controls above the Log view work area.
Using log pages

Button controls above the Log view area

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Start logging" /></td>
<td>Start logging</td>
</tr>
<tr>
<td><img src="image" alt="Stop logging" /></td>
<td>Stop logging</td>
</tr>
<tr>
<td><img src="image" alt="Change log file" /></td>
<td>Change log file</td>
</tr>
<tr>
<td><img src="image" alt="Log to file" /></td>
<td>Log to file</td>
</tr>
</tbody>
</table>

Saving log files

1. Save log files by using the log to file function. Select Log > Log to File from the PLUS+1® Service Tool window menu.
2. Select or create a log file to save in the Select logfile window.

Any logging activity will be recorded in a log file. Logfiles (*.LDF) for basic pages will be stored as LDF/LHF files.

Log files for advanced pages will be stored as LDF/GEN files in the selected log folder.
Using log pages

When log activity is started, log data recording will be automatically saved.

Monitor log files

1. Verify Log to File activity by monitoring Log status box in lower left hand of PLUS+1® Service Tool window.

2. To play saved log files select Log > Play Log File > Open from the PLUS+1® Service Tool window menu bar or click the Open Saved Log File icon from the PLUS+1® Service Tool window toolbar.

3. Select the file from the Open dialog window and click Open.
Using log pages

Log file playback

Choose either one:

- Select Log > Play Log File > Play in the PLUS+1® Service Tool window menu
- Click the Play icon from the PLUS+1® Service Tool window toolbar.

Menu view

![Menu View](image)

Only data is displayed during playback of basic log pages. Images, if added, are not displayed.

Log file playback information (activity status, file name, date and time stamp) is displayed in the bottom left-hand corner of the PLUS+1® Service Tool window.

Log file playback can be controlled by using the Change Position in Log File, Play, Stop, Pause and Step Forward in Log File controls.

Toolbar view

![Toolbar View](image)

Log file process

There are two ways to open logged file:

1. Select from the PLUS+1® Service Tool window menu Log > Play Log File > Open
Using log pages

2. Click from the Log File toolbar **Open > Saved Log File**

3. Select Log File in the **Open** dialog box, and click **Open**.

![Image showing Open dialog box]

The Log File is now open in the PLUS+1® Service Tool window.

Exporting log files to spreadsheet

Log files can be exported to any **CSV** format spreadsheet program (such as, Microsoft Excel® and Google Docs™). The PLUS+1® Service Tool defaults to Microsoft Excel® csv delimiters for exporting database files.

Default delimiter

1. **Export** one of two ways:
   - From the PLUS+1® Service Tool window menu select **Log > Play Log file > Export...**

   ![Image showing menu example]

   **PLUS+1® Service Tool window menu example**
Using log pages

- From the Log File toolbar click on **Export**.

2. **Save As** dialog box, click Select the file for export in the **Save**.
The file will be exported and saved as a .csv file to the Log folder of the application.

3. **Click OK**

The file is now ready to be opened with Microsoft Excel®.

Selecting a different delimiter

**Options > Settings** in the PLUS+1® Service Tool window menu.
Using parameter pages

Manual parameter upload and download

1. Use the Parameter Upload and Parameter Download functions to enter and verify operating values to the controller.
2. Upload parameter values to the PLUS+1® Service Tool from the controller by selecting Parameter > Upload from the PLUS+1® Service Tool window menu. Parameters can also be uploaded using the Upload button from the toolbar.
3. Download parameter values from the PLUS+1® Service Tool to the controller by selecting Parameter > Download in the PLUS+1® Service Tool window menu. Parameters can also be downloaded using the Download button from the toolbar.

In a basic parameter, controller values are updated in the ECU values fields of the Design Screen (Basic) pane of the PLUS+1® Service Tool window.

Upload or Download parameters from or to ECU

Only Parameters selected for download will be downloaded.

Selecting parameter for download

1. Download parameter values by checking the Download check box for each parameter to download, and press the Download parameter button in the toolbar.

Basic Parameter List view

Advanced Parameter Page view

When changing a parameter value, the check box will automatically be checked.
Using parameter pages

Unchecked parameter values will not be downloaded.

2. Press the **Check All** button to check all parameters in the list.
3. Press the **Uncheck All** button to uncheck all parameters in the list.
4. Press the **Set default** button to set all parameter values to the default value (specified in design mode).

Use a period (.), a comma (,) or the decimal symbol from the Windows regional settings when entering decimal values.

Importing parameter values

When importing parameters, an error dialog will show up if any values (from file) are not within the parameter range set by the designer.

Automatic parameter upload function

ECU parameter values are automatically uploaded when a parameter page is selected.

If **Cancel** is selected, parameter values will be set to the default settings. A notification message will be displayed.

If the ECU is not connected, parameters will not be automatically uploaded.

Parameter upload and download error messages

If errors occur during parameter upload and/or download, error messages will be displayed.
Using parameter pages

In basic pages, parameters containing errors will be marked by red exclamation circle.

In advanced pages, parameters components containing errors will be shown in the tool tip.

If the property “Indicate changed value” has been enabled by the designer, the parameter edit field background will turn yellow when the edit value differs from the current ECU value.

Parameter file export

1. Created parameter files can be imported or exported from a local PC by selecting Parameter > File Import and File Export functions.

These files are called parameter data files and are saved in an xml file format.
Using parameter pages

Parameter data files contain the ECU, signal name and value together with a version number on the file format.

2. Save the parameter data file using the **Save As** dialog box:

Only the currently displayed and available parameter values can be saved.
If the user does not have access to the parameter, the parameter cannot be saved.

Parameter file import

1. Import files by selecting **Parameter > File Import** from the Menu Bar or click on **File Import** from the PLUS+1® Service Tool window toolbar.
2. Select the desired file for value import.
Using parameter pages

Only values for displayed signal names in the current parameter page will be changed.
The imported file data uses signal names to reference imported value locations.
If no signal name match is found, data will remain unchanged. Parameter values that are locked will
remain unchanged.

Generating parameter reports

Database readable reports of parameter activity can be generated using the Generate Report function.
1. In the PLUS+1® Service Tool window menu select Parameter > Generate Report or from the toolbar
click on the Generate Report icon.
Using parameter pages

2. Name the file in the Generate Report dialog box.

The file will be saved as a .csv file.

![Generate Report dialog box]

The file can be opened by many common database applications, such as Microsoft Excel®.

![Microsoft Excel](image)

Parameter memory transfer

Parameter memory values can be transferred from one controller to another using the Parameter memory transfer feature.

All parameters referenced in the diagnostic data (except those that are write-protected) can be uploaded and downloaded regardless of user access level.

The memory value that is transferred is from the NV (non-volatile) memory value and not the VAL (value) signal.

For more information on the difference between NV and VAL values, reference the PLUS+1® GUIDE User Manual, 10100824.

Upload parameter values

1. Right-click the current ECU of an open application in the PLUS+1® Service Tool window. Select ECU Parameter Transfer to open a submenu.
Using parameter pages

2. Select **Upload all parameter values**.

3. In the **ECU Parameter Transfer - Upload** dialog window name the file and click **Save**. The parameters will be stored as a .PIT file.

Download parameter values

1. Right-click the current ECU and select **ECU Parameter Transfer**.
2. Select **Download all parameter values**.
Using parameter pages

3. In the ECU Parameter Transfer - Download dialog window select desired .P1T file and click Open. The parameter values will then be transferred to the current ECU.

This will download all available parameters into the current ECU.

It is only possible to download parameter values to an application which matches the parameter set in the .P1T file.

If a parameter cannot be uploaded or downloaded, a Parameter Upload/Parameter Download Error dialog window will be displayed. Specific parameter and error information will be listed.

Decrypting P1T files

Only .P1T files created in PLUS+1® Service Tool 10.0 or later can be decrypted.

1. Decrypt a .P1T file to view the ECU and parameter information by selecting the menu item File > ECU Parameter Transfer > Decrypt ECU Parameter Transfer file...
Using parameter pages

2. In the **ECU Parameter Transfer - Decrypt** dialog window select desired .P1T file and click **Open**.

3. In the next **ECU Parameter Transfer - Decrypt** dialog window name the file and click **Save**. Two output formats are available, .CSV and .JSON.

If the ECU application, from which the .P1T file was created, required a Tool Key, then the same Tool Key must be active in the PLUS+1® Service Tool to be able to decrypt the .P1T file.

The content in the decrypted information will depend on the access levels in the active license.
Creating P1T files

P1T files can be created based on a decrypted .CSV or .JSON file.

1. Select the menu item File > ECU Parameter Transfer > Create ECU Parameter Transfer file...

2. In the ECU Parameter Transfer - Create dialog window select desired .CSV or .JSON file and click Open.

If the input file does not contain a Tool Key (or if it is invalid) a dialog will show up, where a Tool Key can be added (recommended).
Using parameter pages

3. In the next **ECU Parameter Transfer - Create** dialog window name the file and click **Save**.
Using contextual help in service applications

Contextual help feature

Service applications may contain contextual help. Contextual help is available when the screen cursor is placed over an advanced page component subject and a question mark is displayed.

Press F1 to display the help topic relevant to the "context" in which the user pressed the key.

For example, pressing F1 in an editor could display a topic on editing, pressing F1 in a configuration dialog could display a topic on the features of that dialog.
Using the Tool Key

Tool Key function

Use the Tool key function to provide customized application protection. For information on license embedded Tool Key options, consult your nearest Danfoss technical sales representative.

There are three ways to set up the Tool Key:

• Manually entered
• Included or embedded in the Service Application File (P1D)
• License embedded

Set up Tool Key information

When downloading the application with Tool Key for the first time it will be necessary to set up the Tool Key information in the PLUS+1® Service Tool.

1. When no Tool key information is found when attempting a download, the following warning messages will appear:

2. Enter Tool Key information by first clicking OK to close the Incorrect Tool Key error message.

3. Next, select Options > Tool Key... from the PLUS+1® Service Tool window menu to open the Tool Key dialog box.
Using the Tool Key

Manually entered Tool Key set up

1. In the Tool Key dialog box select **Add**.

   ![Tool Key dialog box](image1)

   A sub dialog box appears.

   ![Sub dialog box](image2)

2. Enter the Tool Key name (description) and the Tool Key password that was created in the PLUS+1® GUIDE application. Click **OK** to close box.

   ![Tool Key sub dialog box](image3)

   The Tool Key has successfully been entered.
Using the Tool Key

3. Select **OK** to save and close.

License embedded Tool Key set up

Tool keys embedded in the active license will appear in the **License Tool Keys** field of the **Tool Key** dialog box.

1. Select Tool Key and click **OK** to activate the selected Tool Key.

2. Select **Add...**
   The Tool key is now active.
Working in normal view

Application log

Record application activity for supported applications and controllers in the Application log function of the PLUS+1® Service Tool. The Application Log writes application-specified information to a flash memory file (PLA file) that can be accessed in the Diagnostic Navigator section of the PLUS+1® Service Tool.

Application data logging writes data to the memory of a Danfoss PLUS+1® controller. The PLUS+1® Service Tool program accesses this data. The program writes data first to an encrypted .p1a (PLUS+1® application data log) file and then, with proper access rights, writes to a CSV (comma-separated value) file.

Access to application log information can be controlled within the PLUS+1® GUIDE software program. You can use access components to restrict the PLUS+1® Service Tool program’s access to the application data log and its contents.

For more information, see the Application Data Logging chapter of the PLUS+1® GUIDE User Manual, 10100824.

Application log file
Working in normal view

1. Double-click to open the encrypted log file.

   ![Image of File Explorer window]

   The file will automatically decode to create and save to an ASCII file.

   The Application Log file can now be decoded into a csv file that can be accessed by many spreadsheet applications.

2. Select in the PLUS+1® Service Tool window menu bar: **File > Decode Application Log File...**
3. Select the file to be decoded

An Application Log File that matches the user access level is created.

**PLUS+1® Service Tool settings options**

Use PLUS+1® Service Tool settings to access general and advanced page setting options. In the main menu bar select **Options > Settings** to open the **Options** window.
Working in normal view

**General**

Use the **General** settings screen to set Tool Key, setup screen display, PLUS+1\* Service Tool background color, and Export Log options.

![General settings options](image)

**General settings options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Theme</strong></td>
<td>Use to select light or dark appearance in user interface.</td>
</tr>
<tr>
<td><strong>Toolbar icon size</strong></td>
<td>Use to select icon size displayed in tool bar.</td>
</tr>
<tr>
<td><strong>Show start page is no Service Application is open</strong></td>
<td>Select check box to display the start page when no Service Application is open.</td>
</tr>
<tr>
<td><strong>Automatically use tool key from Service Application File</strong></td>
<td>Select check box to always use the tool key embedded in the *.P1D file.</td>
</tr>
<tr>
<td><strong>Automatically scan for service application file</strong></td>
<td>Select to automatically scan for service application files after automatic system scan is completed.</td>
</tr>
<tr>
<td><strong>Enable baudrate setting in status bar</strong></td>
<td>Select to enable manual baudrate setting.</td>
</tr>
<tr>
<td><strong>Create backup file when overwriting Service Application files</strong></td>
<td>Select check box to automatically create a *.P1D backup file.</td>
</tr>
<tr>
<td><strong>Startup screen delay</strong></td>
<td>Enter time that startup screen will be display at start up.</td>
</tr>
<tr>
<td><strong>Export log file</strong></td>
<td>Select to choose delimiter for log file export. The default is Windows</td>
</tr>
</tbody>
</table>

**Advanced Screen**

In the Advanced Page Design - Settings select **Display tooltip on components** and **Display help cursor on help enabled components** cursor options.
Working in normal view

### Advanced page setting options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display tooltip on components</td>
<td>Select to enable visible tooltip functionality when mouse is over tool tip function screen items.</td>
</tr>
<tr>
<td>Time to display tooltip(s)</td>
<td>The time the tool tip is shown (1 to 60 seconds).</td>
</tr>
<tr>
<td>Display help cursor on help enabled components</td>
<td>Select to display help cursor hand image when mouse is over help enabled components.</td>
</tr>
</tbody>
</table>

### File association

**File association setting options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check or uncheck box</td>
<td>If checked, will check at startup if this version of PLUS+1® Service Tool is the default associated application for P1D, P1H, and LHX file extensions.</td>
</tr>
</tbody>
</table>

### File download

Use the File Download setting to select either to always display a parameter settings message or to only display a message when downloading a file.
Working in normal view

Warnings

Check box to display a warning message if opening a P1D/P1H file with an older file format.
Monitoring the CAN bus

Use the CAN Monitor to monitor all CAN bus messages and bus load. Messages are displayed in either decimal or hexadecimal format and can be logged to a file.

CAN Monitor is a basic general-purpose CAN bus log tool, it is not a substitute for a full-scale CAN analyzer tool.
To use the CAN Monitor you need to have an Express or Professional license installed in the License Manager.

Monitor CAN bus messages and bus load

1. Select menu item **Tools > CAN Monitor**.

The PLUS+1® **CAN Monitor** is a standalone window that can be used along side the PLUS+1® Service Tool.

**Tool Bar buttons**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start</td>
<td>Start monitoring the CAN bus.</td>
</tr>
<tr>
<td>2</td>
<td>Stop</td>
<td>Stop monitoring the CAN bus.</td>
</tr>
</tbody>
</table>
Monitoring the CAN bus

**Tool Bar buttons (continued)**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Log to file</td>
<td>Log all CAN bus messages to file. The current settings will be applied to the file content.</td>
</tr>
<tr>
<td>4</td>
<td>Options</td>
<td>Open the Options dialog.</td>
</tr>
<tr>
<td>5</td>
<td>Close</td>
<td>Close the CAN Monitor window.</td>
</tr>
</tbody>
</table>

**CAN messages in main log panel**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Chn</td>
<td>Active channel ID in the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>7</td>
<td>Identifier</td>
<td>CAN message identifier.</td>
</tr>
<tr>
<td>8</td>
<td>Flg</td>
<td>CAN message flag, empty for standard CAN messages, X for extended.</td>
</tr>
<tr>
<td>9</td>
<td>DLC</td>
<td>Data length code, the amount of data bytes in the message.</td>
</tr>
<tr>
<td>10</td>
<td>D...0...1...2...3...4...5...6...D...7</td>
<td>The content in the CAN message data bytes.</td>
</tr>
<tr>
<td>11</td>
<td>Time</td>
<td>The CAN message time stamp, displayed in seconds since the logging was started.</td>
</tr>
<tr>
<td>12</td>
<td>Dir</td>
<td>The CAN message direction R, when received by the PLUS+1® Service Tool and T when sent from the PLUS+1® Service Tool.</td>
</tr>
</tbody>
</table>

The status bar shows the current bus load.

2. Right-click the main panel to show a menu where you can switch to **Fixed Positions** mode, (for more information, see **Options** on page 65), copy the logged content to clipboard and clear the log window.
Monitoring the CAN bus

Options

Press the **Options** button to display the **Options** dialog.

**General options**

<table>
<thead>
<tr>
<th>Numeric base</th>
<th>Select decimal or hexadecimal format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Positions</td>
<td>Check option to enable <strong>Fixed Positions</strong> mode. In this mode, each CAN ID will be displayed on a single line and change the content each time a message with the same CAN ID is received/sent.</td>
</tr>
</tbody>
</table>
### Monitoring the CAN bus

#### Pass filter options

<table>
<thead>
<tr>
<th>Enable CAN ID pass filter</th>
<th>Check option to enable the pass filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower limit</td>
<td>Lower limit of CAN message ID's that shall pass the filter.</td>
</tr>
<tr>
<td>Upper limit</td>
<td>Upper limit of CAN message ID's that shall pass the filter.</td>
</tr>
</tbody>
</table>

Lower and Upper limits can be entered in either decimal or hexadecimal (for example ‘$FF’ or ‘0xFF’) format.
PLUS+1® Service Tool command line mode

Use the PLUS+1® Service Tool command line interface to perform tasks, such as testing a continuous integration (CI) build agent.

P1Diagnostics

The executable is named Plus1_Diag.exe and it can be found in the /P1Tools/P1Diagnostics installation folder.

Plus1_Diag can be run in 3 modes: GUI, CLI and GUI+CLI.

EXE modes

<table>
<thead>
<tr>
<th>Modes</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GUI</td>
<td>PLUS+1® Service Tool will provide a standard Windows desktop user interface.</td>
</tr>
<tr>
<td>CLI</td>
<td>PLUS+1® Service Tool will provide a command line interface, without graphical elements.</td>
</tr>
<tr>
<td>GUI+CLI</td>
<td>PLUS+1® Service Tool will provide a combined interface where information will be provided both in the graphical and the command line interfaces.</td>
</tr>
</tbody>
</table>

Command, Configuration, and Command Modifier Parameters

Command Parameters

<table>
<thead>
<tr>
<th>Name Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-run-script &lt;P1J file&gt; &lt;Script function&gt;</td>
<td>Run the specified script function and then terminate. This command requires exactly two parameters, a P1J file and a script function. If the script is run successfully, then the exit code will be zero (0). Otherwise, the exit code will be one (1).</td>
</tr>
<tr>
<td>-download-file-to-ecu &lt;Application file&gt;</td>
<td>Download the specified file to the connected system and then terminate. The application(s) will automatically be matched to the available ECU(s). No attempt to download any file will be done unless the mapping is clear. This command requires exactly 1 application download file. If file download succeeds, then the exit code will be zero (0). Otherwise, the exit code will be one (1).</td>
</tr>
<tr>
<td>-decrypt-p1t &lt;P1T file&gt; &lt;Decrypted output file&gt;</td>
<td>Decrypt the P1T file and then terminate. This command requires exactly 2 parameters, a P1J file and a CSV/JSON output file. If the decryption succeeds, then the exit code will be zero (0). Otherwise, the exit code will be one (1).</td>
</tr>
<tr>
<td>-create-p1t &lt;Decrypted input file&gt; &lt;P1T file&gt;</td>
<td>Create a P1T file and then terminate. This command requires exactly 2 parameters, a CSV/JSON input file and a P1T output file name. If the creation succeeds, then the exit code will be zero (0). Otherwise, the exit code will be one (1).</td>
</tr>
</tbody>
</table>
PLUS+1® Service Tool command line mode

Command Parameters (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-export-p1log-to-csv &lt;Input file&gt; &lt;Output file&gt;</td>
<td>Export the specified P1 log/LDF file to CSV format and then terminate. This command requires exactly 2 parameters, a P1 log or LDF file and a CSV output file. If the export succeeds, then the exit code will be zero (0). Otherwise, the exit code will be one (1).</td>
</tr>
<tr>
<td>--version</td>
<td>Prints the PLUS+1® Service Tool version. Must not be combined with any other parameter.</td>
</tr>
<tr>
<td>/? --help</td>
<td>Prints information about CLI usage. Must not be combined with any other parameter.</td>
</tr>
</tbody>
</table>

Configuration Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-use-gateway &lt;Gateway name&gt;</td>
<td>Specifies which gateway to select when starting the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>-use-channel &lt;Channel name&gt;</td>
<td>Specifies which gateway channel to select when starting the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>-use-baudrate &lt;Baud rate&gt;</td>
<td>Starts the PLUS+1® Service Tool in normal view.</td>
</tr>
<tr>
<td>-normal-view</td>
<td>Starts the PLUS+1® Service Tool in normal view.</td>
</tr>
<tr>
<td>-design-view</td>
<td>Starts the PLUS+1® Service Tool in design view.</td>
</tr>
<tr>
<td>-online-mode</td>
<td>Starts the PLUS+1® Service Tool in online mode.</td>
</tr>
<tr>
<td>-offline-mode</td>
<td>Starts the PLUS+1® Service Tool in offline mode.</td>
</tr>
</tbody>
</table>

Command Modifier Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-headless</td>
<td>Run the PLUS+1® Service Tool in CLI mode only. Can only be used in combination with a command.</td>
</tr>
<tr>
<td>-keep-cli</td>
<td>The CLI window will not be hidden. May be used in combination with a command, or just a Service Application file.</td>
</tr>
<tr>
<td>-silent</td>
<td>Run the PLUS+1® Service Tool in silent mode. In silent mode, the PLUS+1® Service Tool will not output to stdout. May be used in combination with a command, or -keep-cli.</td>
</tr>
<tr>
<td>-very-silent</td>
<td>Run the PLUS+1® Service Tool in very silent mode. In very silent mode, the PLUS+1® Service Tool will not output to either stdout or stderr. Should normally only be used in combination with -headless.</td>
</tr>
</tbody>
</table>

Examples

Download a file to ECU from command line:
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diagnostics\P1Diagnostics\P1Diagnostics.exle" -headless -download-file-to-ecu "C:\Projects\DownloadPackage.mlhx"

Run a script function from command line (Add-On license required: 'ST_Pro*'):
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diagnostics\P1Diagnostics.exle" -headless -run-script "C:\Projects\ScriptFunctions.p1j" "MyScriptFunction"
Decrypt a P1T file from command line:

```
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diag.exe"-headless -decrypt-p1t
"C:\Projects\EcuParameterTransferFile.p1t" "C:\Projects\DecryptedTransferFile.json"
```

Create a P1T file from command line:

```
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diag.exe"-headless -create-p1t
"C:\Projects\DecryptedTransferFile.json" "C:\Projects\EcuParameterTransferFile.p1t"
```

Export a P1log file to CSV from command line:

```
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diag.exe"-headless -export-p1log-to-csv
"C:\Projects\MachineLogFile.p1log" "C:\Projects\MachineLogFile.csv"
```

Use a specific gateway, channel and baud rate:

```
"C:\Program Files (x86)\Danfoss\PLUS1\11.0\P1Tools\P1Diagnostics\P1Diag.exe"-headless <command> -
use-gateway "CG150" -use-channel "CG150 #0 (Channel 0)" -use-baudrate "250000"
```
Menu bar

Menu descriptions

**Menu bar break out**

**File**
- New
- Open
- Open Recent
- Save
- Save As
- Close
- Replace Missing ECU
- Replace Existing ECU
- Scan for Diagnostic
- Scan System
- Decode Application Log File
- File Download
- Exit

**View**
- Normal View
- Design View
- Diagnostic Navigator
- Default Layout
- Toolbars

**Log**
- New Log Function
- New Parameter Function
- Rename Selected Function
- Delete Selected Function
- Design Selected Function
- System Configuration
- Action
- Design
- Hardware
- View
- Play Log File
- Help
- External Tools

**Parameter**
- Start Logging
- Stop Logging
- Change Log Frequency
- Log to File
- Play Log File
- Basic
- Advanced

**Communication**
- Upload
- Download
- Set Default
- File Import
- File Export
- Generate Report

**Options**
- Open
- Export
- Position
- Play
- Stop
- Pause
- Step

**Tools**
- Communication
- Options
- Tools
- Help

**Help**
- Help Contents
- User Manual
- Release Notes
- Create Troubleshooting File
- About PLUS+1 GUIDE Service Tool

**Automatic System Scan**
- No Automatic Scan
- Ask Before Scan
- Scan Automatically

**Tool Key**
- CG150
- DP600
- UCAN
- Application Baudrate
- Download Baudrate

**License Manager**
- Customize

**Online**
- Online

**Offline**
- Offline

**Settings**
- Settings

**Recover ECU**
Menu bar

File menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new service application file within the diagnostic navigator tab window.</td>
</tr>
<tr>
<td>Open...</td>
<td>Displays the Open dialog box. Use this dialog box to open existing P1D format application files.</td>
</tr>
<tr>
<td>Open Recent</td>
<td>Displays list of five recently opened P1D files for quick access.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the current program files to its previously selected file location.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the current program files to its previously selected file location. This selection is disabled in Normal view.</td>
</tr>
<tr>
<td>Save As...</td>
<td>Displays the Save service application dialog box. Use this dialog box to save current service application file. This selection is disabled in Normal view.</td>
</tr>
<tr>
<td>Install Diagnostic Data...</td>
<td>Select to manually install diagnostic data files.</td>
</tr>
<tr>
<td>Replace Missing ECU...</td>
<td>Select this option for program to scan application for any missing ECU in all log and parameter functions.</td>
</tr>
<tr>
<td>Replace Existing ECU...</td>
<td>Select this option for program to scan application for unused ECU available for replacement in log and parameter functions.</td>
</tr>
<tr>
<td>Scan for Service File...</td>
<td>Displays the Scan Connected System dialog box. The dialog box will automatically scan for P1D service application files.</td>
</tr>
</tbody>
</table>

File menu description

**File**

Use the commands in this menu to create, open, save, scan for and download service application file.

**New**

Creates a new service application file within the diagnostic navigator tab window.

**Open**

Displays the Open dialog box. Use this dialog box to open existing P1D format application files.

**Open Recent**

Displays list of five recently opened P1D files for quick access.

**Close**

Closes the current program files to its previously selected file location.

**Save**

Saves the current program files to its previously selected file location. This selection is disabled in Normal view.

**Save As**

Displays the Save service application dialog box. Use this dialog box to save current service application file. This selection is disabled in Normal view.

**Install Diagnostic Data...**

Select to manually install diagnostic data files.

**Replace Missing ECU...**

Select this option for program to scan application for any missing ECU in all log and parameter functions.

**Replace Existing ECU...**

Select this option for program to scan application for unused ECU available for replacement in log and parameter functions.

**Scan for Service File...**

Displays the Scan Connected System dialog box. The dialog box will automatically scan for P1D service application files.
Menu bar

File menu description (continued)

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scan System...</td>
<td>Displays the Scan Connected System dialog box. The dialog box will automatically scan system for connected equipment.</td>
</tr>
<tr>
<td>File Download...</td>
<td>Displays the Application File Download dialog box. Use this dialog box to download file programs into the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>File Properties...</td>
<td>Select the view Service Application file details.</td>
</tr>
<tr>
<td>Read ECU History...</td>
<td>Select to show ECU history in log form.</td>
</tr>
<tr>
<td>ECU Parameter Transfer</td>
<td>Select to upload or download parameter values to or from another location.</td>
</tr>
<tr>
<td>Read Application Log...</td>
<td>Select to read saved application log data.</td>
</tr>
<tr>
<td>Decode Application Log File...</td>
<td>Use to convert application log files into a CSV file format for spreadsheet view.</td>
</tr>
<tr>
<td>Exit</td>
<td>Closes the PLUS+1® Service Tool.</td>
</tr>
</tbody>
</table>

View menu

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal View Ctrl+Alt+N</td>
<td>Select this option to use the PLUS+1® Service Tool without the log and parameter design functions.</td>
</tr>
<tr>
<td>Design View Ctrl+Alt+D</td>
<td>Select this option to use the PLUS+1® Service Tool with log and parameter design functions.</td>
</tr>
<tr>
<td>Diagnostic Navigator</td>
<td>Select this option to display the diagnostic navigator pane in the PLUS+1® Service Tool window.</td>
</tr>
<tr>
<td>Default Layout</td>
<td>Select this option to use the PLUS+1® Service Tool with all menus and tool bar options available.</td>
</tr>
<tr>
<td>Toolbars</td>
<td>Use this dialog box to select tool bar icons to for display in tool bar. Use the tool bar buttons to quickly access frequently used service and diagnostic functions</td>
</tr>
</tbody>
</table>
## Menu bar

### Design menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Log Function</td>
<td>Creates a new log function in the diagnostic navigator pane of the PLUS+1® Service Tool window.</td>
</tr>
<tr>
<td>New Parameter Function</td>
<td>Creates a new parameter function in the diagnostic navigator pane of the PLUS+1® Service Tool window.</td>
</tr>
<tr>
<td>Rename</td>
<td>Select this option to rename selected log and parameter functions.</td>
</tr>
<tr>
<td>Find/Replace Signal Names...</td>
<td>Find, replace or insert signal names in all or part of selected ECUs.</td>
</tr>
<tr>
<td>Design...</td>
<td></td>
</tr>
<tr>
<td>Delete...</td>
<td>Select this option to delete log and parameter functions.</td>
</tr>
<tr>
<td>Lock File...</td>
<td>Select to permanently lock P1D and P1H files.</td>
</tr>
<tr>
<td>System Configuration...</td>
<td>Define display style, scan options and tooltip information for a selected system.</td>
</tr>
<tr>
<td>Tool Key in Diagnostic File...</td>
<td>Create a tool key for customized application protection.</td>
</tr>
<tr>
<td>Diagnostic File Properties...</td>
<td></td>
</tr>
</tbody>
</table>

### Log menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Logging</td>
<td>Select this option to begin logging file.</td>
</tr>
<tr>
<td>Stop Logging</td>
<td>Select this option to stop logging file.</td>
</tr>
<tr>
<td>Change Log Period...</td>
<td>Select this option to open Change Log period dialog box</td>
</tr>
<tr>
<td>Log to File...</td>
<td>Use this dialog box to change log frequency (in millisecond increments)</td>
</tr>
<tr>
<td>Play Log File</td>
<td></td>
</tr>
</tbody>
</table>

### Design menu description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design</td>
<td>Use the commands in this menu to design, create and modify log and parameter functions in the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>New Log Function</td>
<td>Creates a new log function in the diagnostic navigator pane of the PLUS+1® Service Tool window.</td>
</tr>
<tr>
<td>New Parameter Function</td>
<td>Creates a new parameter function in the diagnostic navigator pane of the PLUS+1® Service Tool window.</td>
</tr>
<tr>
<td>Rename</td>
<td>Select this option to rename selected log and parameter functions.</td>
</tr>
<tr>
<td>Find/Replace Signal Names...</td>
<td>Find, replace or insert signal names in all or part of selected ECUs.</td>
</tr>
<tr>
<td>Design...</td>
<td></td>
</tr>
<tr>
<td>Delete...</td>
<td>Select this option to delete log and parameter functions.</td>
</tr>
<tr>
<td>Lock File...</td>
<td>Select to permanently lock P1D and P1H files.</td>
</tr>
<tr>
<td>System Configuration...</td>
<td>Define display style, scan options and tooltip information for a selected system.</td>
</tr>
<tr>
<td>Tool Key in Diagnostic File...</td>
<td>Create a tool key for customized application protection.</td>
</tr>
<tr>
<td>Diagnostic File Properties...</td>
<td></td>
</tr>
</tbody>
</table>

### Log menu description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log</td>
<td>Use the commands in this menu to start, stop, change and play log functions.</td>
</tr>
<tr>
<td>Start Logging</td>
<td>Select this option to begin logging file.</td>
</tr>
<tr>
<td>Stop Logging</td>
<td>Select this option to stop logging file.</td>
</tr>
<tr>
<td>Change Log Period...</td>
<td>Select this option to open Change Log period dialog box</td>
</tr>
<tr>
<td>Log to File...</td>
<td>Use this dialog box to change log frequency (in millisecond increments)</td>
</tr>
<tr>
<td>Play Log File</td>
<td></td>
</tr>
</tbody>
</table>
Menu bar

Log menu description (continued)

<table>
<thead>
<tr>
<th>Log menu description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log to File...</td>
<td>Select this option to open the Select log file dialog box. Use this dialog box to choose file to save log information.</td>
</tr>
<tr>
<td>Play Log File</td>
<td>Use to play saved log file.</td>
</tr>
<tr>
<td>Open</td>
<td>Opens Open File for Download dialog box. Use dialog box to select log file to play.</td>
</tr>
<tr>
<td>Export</td>
<td>Use to export log file.</td>
</tr>
<tr>
<td>Position</td>
<td>Opens LogPlayPosForm slide bar. Use slide bar to change play position in log file.</td>
</tr>
<tr>
<td>Play</td>
<td>Select to begin log file playback.</td>
</tr>
<tr>
<td>Stop</td>
<td>Select to stop log file playback.</td>
</tr>
<tr>
<td>Pause</td>
<td>Select to pause the log file playback.</td>
</tr>
<tr>
<td>Step</td>
<td>Select for frame-by-frame control playback of log file.</td>
</tr>
</tbody>
</table>

Parameter menu

<table>
<thead>
<tr>
<th>Parameter menu description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload</td>
<td>F2</td>
</tr>
<tr>
<td>Download</td>
<td>F4</td>
</tr>
<tr>
<td>Set Default</td>
<td></td>
</tr>
<tr>
<td>File import...</td>
<td></td>
</tr>
<tr>
<td>File Export...</td>
<td></td>
</tr>
<tr>
<td>Check all parameters for download</td>
<td></td>
</tr>
<tr>
<td>Uncheck all parameters for download</td>
<td></td>
</tr>
<tr>
<td>Generate Report...</td>
<td>Ctrl+R</td>
</tr>
</tbody>
</table>

Parameter menu description

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Use the commands in this menu to read and write parameter values to the PLUS+1® GUIDE and generate parameter reports.</td>
</tr>
<tr>
<td>Upload</td>
<td>Select Read to read parameter settings from controller to the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>Download</td>
<td>Select Write to write parameter settings from the PLUS+1® Service Tool to the controller.</td>
</tr>
<tr>
<td>Set Default</td>
<td>Select to reset default parameter values.</td>
</tr>
<tr>
<td>File Import...</td>
<td>Select to import parameter files.</td>
</tr>
<tr>
<td>File Export...</td>
<td>Select to export parameter values.</td>
</tr>
<tr>
<td>Check all parameters for download</td>
<td>Choose to select all parameters for download.</td>
</tr>
<tr>
<td>Uncheck all parameters for download</td>
<td>Choose to unselect all parameters for download.</td>
</tr>
<tr>
<td>Generate Report...</td>
<td>Select Generate Report to save parameter report to PLUS+1® Service Tool.</td>
</tr>
</tbody>
</table>
Menu bar

Communication menu

- **Online Mode**
- **Offline Mode**
- **Gateway**
- **Baudrate**
- **Protocols...**
- **Recover ECU...**

Communication menu description

<table>
<thead>
<tr>
<th>Communication</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication</td>
<td>Use the commands in this menu to select online or offline modes and Toolbar settings.</td>
</tr>
<tr>
<td>Online Mode</td>
<td>Toggle this menu option to work in online mode.</td>
</tr>
<tr>
<td>Offline Mode</td>
<td>Toggle this menu option to work in offline mode.</td>
</tr>
<tr>
<td>Gateway</td>
<td>Select connection device to enable CAN communication and specific channel selections.</td>
</tr>
<tr>
<td>Baudrate</td>
<td>Select preferred baudrate (default baudrate is 250k).</td>
</tr>
<tr>
<td>Protocols...</td>
<td>Select communication protocols.</td>
</tr>
<tr>
<td>Recover ECU...</td>
<td>Use to relink non-responding ECU communications.</td>
</tr>
</tbody>
</table>

Options menu

- **Automatic System Scan**
- **Tool Key...**
- **Settings...**

Options menu description

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options</td>
<td>Use the commands in this menu to select system scan settings, access the Tool Key dialog box and select background color and startup screen delay settings.</td>
</tr>
<tr>
<td>Automatic System Scan</td>
<td>The system will automatically scan for system files.</td>
</tr>
<tr>
<td>Tool Key...</td>
<td>Use to lock log and parameter files.</td>
</tr>
<tr>
<td>Settings...</td>
<td>Displays the Settings dialog box. Use dialog box to select general and advance screen settings options.</td>
</tr>
</tbody>
</table>

Tools menu

- **License Manager...**
- **Customize...**

Tools menu description

<table>
<thead>
<tr>
<th>Tools</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools</td>
<td>Use the command in this menu to access License Manager.</td>
</tr>
<tr>
<td>License Manager</td>
<td>Displays the License Manager dialog box. Use this dialog box to add a PLUS+1® Service Tool license, delete a license, activate a license or get a license.</td>
</tr>
<tr>
<td>Customize...</td>
<td>Use to create custom toolbar button options.</td>
</tr>
</tbody>
</table>
## Help Menu

<table>
<thead>
<tr>
<th>Help Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>Use the command in this menu to access help and information about the PLUS+1® Service Tool.</td>
</tr>
<tr>
<td>Help Contents</td>
<td>Opens in-application help file.</td>
</tr>
<tr>
<td>Design Manual</td>
<td></td>
</tr>
<tr>
<td>Release Notes</td>
<td>Last minute news and notes.</td>
</tr>
<tr>
<td>PLUS+1 Online</td>
<td>Select to visit the PLUS+1® website.</td>
</tr>
<tr>
<td>Support</td>
<td>Use Support to access the PLUS+1® support website, create a troubleshooting file for diagnosis or to open your desktop for PLUS+1® Helpdesk access.</td>
</tr>
<tr>
<td>About PLUS+1 Service Tool</td>
<td>Select to view PLUS+1® Service Tool and license information.</td>
</tr>
</tbody>
</table>
# Toolbar

## Toolbar descriptions

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Scan for Service File</td>
</tr>
<tr>
<td>2</td>
<td>File Download</td>
</tr>
<tr>
<td>3</td>
<td>New Service Application</td>
</tr>
<tr>
<td>4</td>
<td>Open Service Application</td>
</tr>
<tr>
<td>5</td>
<td>Save Service Application</td>
</tr>
<tr>
<td>6</td>
<td>Design Selected Page</td>
</tr>
<tr>
<td>7</td>
<td>Replace Missing ECU</td>
</tr>
<tr>
<td>8</td>
<td>Replace Existing ECU</td>
</tr>
<tr>
<td>9</td>
<td>Scan System</td>
</tr>
<tr>
<td>10</td>
<td>Diagnostic Navigator</td>
</tr>
</tbody>
</table>

## Log File toolbar

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start Logging</td>
</tr>
<tr>
<td>2</td>
<td>Stop Logging</td>
</tr>
<tr>
<td>3</td>
<td>Change Period</td>
</tr>
<tr>
<td>4</td>
<td>Log to file</td>
</tr>
</tbody>
</table>
### Toolbar

**Parameters toolbar**

<p>| | | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Upload Parameters from ECU</td>
<td>Select to upload all parameter values from the ECU.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Download Parameters from ECU</td>
<td>Select to download all parameter values from the ECU.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Set All Values to Default Values</td>
<td>Select to make current values as default values.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Import Values from a Parameter Data File</td>
<td>Select to import values from a parameter data file into the current ECU.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Export Values to a Parameter Data File</td>
<td>Select to export parameter values.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Check All Parameters for Download</td>
<td>Select to select all parameters for download.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Uncheck All Parameters for Download</td>
<td>Select to deselect all parameters for download.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Create a Report File from the Current Information</td>
<td>Select to save parameter report to PLUS+1® Service Tool.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Danfoss Power Solutions is a global manufacturer and supplier of high-quality hydraulic and electric components. We specialize in providing state-of-the-art technology and solutions that excel in the harsh operating conditions of the mobile off-highway market as well as the marine sector. Building on our extensive applications expertise, we work closely with you to ensure exceptional performance for a broad range of applications. We help you and other customers around the world speed up system development, reduce costs and bring vehicles and vessels to market faster.

Danfoss Power Solutions – your strongest partner in mobile hydraulics and mobile electrification.

Go to www.danfoss.com for further product information.

We offer you expert worldwide support for ensuring the best possible solutions for outstanding performance. And with an extensive network of Global Service Partners, we also provide you with comprehensive global service for all of our components.

Products we offer:
- DCV directional control valves
- Electric converters
- Electric machines
- Electric motors
- Gear motors
- Gear pumps
- Hydrostatic motors
- Hydrostatic pumps
- Orbital motors
- PLUS+1® controllers
- PLUS+1® displays
- PLUS+1® joysticks and pedals
- PLUS+1® operator interfaces
- PLUS+1® sensors
- PLUS+1® software
- PLUS+1® software services, support and training
- Position controls and sensors
- PVG proportional valves
- Steering components and systems
- Telematics

Hydro-Gear
www.hydro-gear.com

Daikin-Sauer-Danfoss
www.daikin-sauer-danfoss.com